NetWorker: Oppretting av en ny klient fullføres ikke med meldingen "is not a valid hostname as it cannot be resolved in DNS" (Er ikke et gyldig vertsnavn fordi det ikke kan løses i DNS)
Zusammenfassung: Å legge til en klient via Egenskaper for ny klient i NetWorker 19.7.0.3 fullføres ikke, og rapporterer feilen "Name is not a valid hostname as it cannot be resolved in DNS. Legg den til i DNS eller vertsfilen, og tøm NetWorker-serverens DNS-hurtigbuffer (dbgcommand -p FlushDnsCache). ...
Dieser Artikel gilt für
Dieser Artikel gilt nicht für
Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden.
In diesem Artikel werden nicht alle Produktversionen aufgeführt.
Symptome
Hvis du legger til en klient via Egenskaper for ny klient i NetWorker 19.7.0.3, fullføres ikke og viser følgende feil:
Figur 1: Skjermbilde av feilmelding
Name is not a valid host name as it cannot be resolved in DNS. Please add it to DNS or the hosts file and flush the NetWorker server's DNS cache (dbgcommand -p FlushDnsCache).
Figur 1: Skjermbilde av feilmelding
Ursache
Vertsnavnet mislykkes med navneløsing enten via DNS eller via «hosts»-filen.
Selv om vertsnavnet løser problemet, hindrer NetWorker DNS-hurtigbufferen klienten i å bli lagt til hvis denne feilmeldingen oppsto tidligere.
Lösung
Legg til klientens vertsnavn i DNS (videresende og reversere oppføringer), eller legg det til i «hosts»-filen ved hjelp av formatet:
IP Address [space/tab] FQDN [space/tab] Short Name
Følg trinnene nedenfor for å "tømme" NetWorker DNS-hurtigbufferen:
- Hent PID-en til nsrd- og nsrexecd-prosessene ved hjelp av kommandoene nedenfor:
Windows:
tasklist | findstr nsrd.exe tasklist | findstr nsrexecd.exe
Linux:
ps -e | grep nsrd ps -e | grep nsrexecd
- Kjør kommandoen nedenfor mot PID-en til "nsrd" og "nsrexecd", og bruk svitsjen som vist:
dbgcommand -p FlushDnsCache
Artikeleigenschaften
Artikelnummer: 000212659
Artikeltyp: Solution
Zuletzt geändert: 29 Juni 2023
Version: 3
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.