ECS: DD Cloud Unitin yhteys katkaistiin http 403 -virheiden vuoksi - käyttö estetty

Zusammenfassung: Pilviyksikön yhteys katkaistiin http 403 -virheiden vuoksi - Käyttö estetty -ongelmaraportointi Data Domainissa

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

Pilviyksikön yhteys katkeaa http 403 -virheiden vuoksi käyttöongelman vuoksi.

DD ilmoittaa seuraavista virheistä.
03/21 07:22:01.838 (tid 0x6991b0): ERROR: CSM cl_curl_write_cb:1680 - Request failed with httpcode:403
03/21 07:22:01.838 (tid 0x6991b0): ERROR: CSM cl_request_convert_httpcode_to_err:1554 - HTTP operation returned code:403, request error:Access Denied [5075], uri:https://emcecs.xxxxxxx.xx.xx:9021/?endpoint, date:Tue, 21 Mar 2023 03:22:01 GMT, bytes_sent:0, bytes:rcvd:0
03/21 07:22:01.838 (tid 0x6991b0): ERROR: csm_provider_version_check:496 - Error (Access Denied) getting the provider version for cloud profile: EMC-ECS
03/21 07:22:01 ERROR: csm_provider_version_check:496 - Error (Access Denied) getting the provider version for cloud profile: EMC-ECS
04/03 18:46:49.710 (tid 0x699060): ERROR: csm_validate_profile_internal:445 - list_bucket failed for profile cloud-ecs101_profile_profile with err 5075: Access Denied
04/03 18:46:49 ERROR: csm_validate_profile_internal:445 - list_bucket failed for profile cloud-ecs101_profile_profile with err 5075: Access Denied

ECS:ssä kpi.Ongelmasta kärsivässä säilössä näkyy 403 virhettä.
Extracting RequestLog data:        DONE

                                 All Requests                                           500 Errors
Node             GETs      PUTs      POSTs     DELETEs   HEADs    Total     GETs    PUTs    POSTs   DELETEs  HEADs   Total
10.xx.xx.001     0         0         0         0         0        0         0       0       0       0        0       0
10.xx.xx.002     0         0         0         0         0        0         0       0       0       0        0       0
10.xx.xx.003     0         0         0         0         0        0         0       0       0       0        0       0
10.xx.xx.004     1         0         0         0         0        1         0       0       0       0        0       0
10.xx.xx.005     0         0         0         0         0        0         0       0       0       0        0       0
10.xx.xx.006     0         0         0         0         0        0         0       0       0       0        0       0
10.xx.xx.007     0         1         0         0         0        1         0       0       0       0        0       0
10.xx.xx.008     0         0         0         0         0        0         0       0       0       0        0       0

Req Totals:      1         1         0         0         0        2         0       0       0       0        0       0
Req Error %:                                                                0.00    0.00    0.00    0.00     0.00    0.00

------------------------------------------------------------------------------------------------------------------------
Error Summary - All Error Codes
------------------------------------------------------------------------------------------------------------------------
Error Code        GET        PUT        POST       HEAD       DELETE     Total

403               1          1          0          0          0          2

Error Totals      1          1          0          0          0          2
------------------------------------------------------------------------------------------------------------------------

Lokeissa näkyy seuraavan kerran vinohälytys 403-virheen jälkeen.
169.254.1.7 dataheadsvc.log.20230413-213831.gz 2023-04-13T15:32:10,334 [qtp1744025389-1494616-0a112bbb:184289e9ad9:fe3c0:4-s3-10.xx.xx.002] ERROR  V2Signer.java (line 168) client/server time skewed. RequestId 0a112bbb:184289e9ad9:fe3c0:4

Ursache

Data Domainissa tai ECS:ssä kellonaikaa ei synkronoida NTP:n kanssa.

Lösung

1. Varmista, että ajan synkronointi tai NTP-ongelmat eivät näy, suorittamalla uusin xDoctor-versio. 

2. Tarkista järjestelmän aika ja laitteistokello kaikissa solmuissa. 
admin@ecsnode1:~> viprexec "hwclock; date"

Output from host : 192.168.219.2
2023-04-14 07:40:03.749250+0000
Fri Apr 14 07:40:04 UTC 2023

Output from host : 192.168.219.3
2023-04-14 07:40:03.748930+0000
Fri Apr 14 07:40:04 UTC 2023

Output from host : 192.168.219.7
2023-04-14 07:40:03.747903+0000
Fri Apr 14 07:40:04 UTC 2023

Output from host : 192.168.219.1
2023-04-14 07:40:03.749030+0000
Fri Apr 14 07:40:04 UTC 2023

Output from host : 192.168.219.4
2023-04-14 07:40:03.749111+0000
Fri Apr 14 07:40:04 UTC 2023

Output from host : 192.168.219.8
2023-04-14 07:40:03.748931+0000
Fri Apr 14 07:40:04 UTC 2023

Output from host : 192.168.219.5
2023-04-14 07:40:03.733340+0000
Fri Apr 14 07:40:04 UTC 2023

Output from host : 192.168.219.6
2023-04-14 07:40:03.729096+0000
Fri Apr 14 07:40:04 UTC 2023

3. Jos ECS-solmuissa on ajan synkronointiongelmia tai laitteistokellojen eroja, ratkaise ne Dellin tuen kanssa.

4. Jos kaikkien ECS-solmujen aika synkronoidaan, ongelma saattaa koskea Data Domainia.

5. Pyydä Data Domain -tukea tarkistamaan ja korjaamaan Data Domainin aika- tai NTP-ongelmat. 

6. Tarkista pilviyksikön tila.

Betroffene Produkte

ECS, Elastic Cloud Storage
Artikeleigenschaften
Artikelnummer: 000212712
Artikeltyp: Solution
Zuletzt geändert: 08 Juni 2023
Version:  2
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.