Avamar: "Det gick inte att spara konsolserverdata på servern" på grund av portskannrar som orsakar hög användning av Java CPU

Summary: Portskannrar orsakar hög Java-processoranvändning, vilket resulterar i ett tömningsfel för Management Console-server (MCS): "Det gick inte att spara konsolserverdata på servern."

Αυτό το άρθρο ισχύει για Αυτό το άρθρο δεν ισχύει για Αυτό το άρθρο δεν συνδέεται με κάποιο συγκεκριμένο προϊόν. Δεν προσδιορίζονται όλες οι εκδόσεις προϊόντων σε αυτό το άρθρο.

Symptoms

Den här händelsen kan loggas som en Dial Home-händelse, en MC UI-händelse eller visas i en PuTTY-session på Avamar Utility Node:

Symptom: 22402, Desc: Could not save console server data to server.
 

Java-processen på Avamar Utility Node körs på 100 % CPU eller högre:

top
top - 10:57:10 up 140 days, 19:57,  2 users,  load average: 2.55, 2.52, 2.48
Tasks: 187 total,   1 running, 186 sleeping,   0 stopped,   0 zombie
Cpu(s): 74.5%us,  0.2%sy,  0.0%ni, 25.4%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:     12028M total,    10789M used,     1238M free,      187M buffers
Swap:     4086M total,       68M used,     4018M free,     7507M cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
12108 admin     20   0 1720m 1.3g  11m S  299 10.9 112556:00 java
13476 admin     20   0 1125m 541m  11m S    0  4.5 157:08.53 java
14055 root      20   0 1485m 158m  10m S    0  1.3 184:58.50 java
 

Ett eller flera av följande fel upptäcks i /usr/local/avamar/var/mc/server_log/axis2.log:

2013-01-24 23:01:42,517 [1031746922@qtp-1453087591-170] ERROR org.apache.axis2.engine.AxisEngine  - The service cannot be found for the endpoint reference (EPR) /php.cgi?/etc/passwd
org.apache.axis2.AxisFault: The service cannot be found for the endpoint reference (EPR) /php.cgi?/etc/passwd
        at org.apache.axis2.engine.DispatchPhase.checkPostConditions(DispatchPhase.java:65)
        at org.apache.axis2.engine.Phase.invoke(Phase.java:334)

2014-04-09 12:44:56,908 [main] INFO  org.apache.axis2.deployment.ServiceDeployer  - Deploying Web service: mcService-server-7.0.0-SNAPSHOT.jar - file:/data01/avamar/var/mc/server_tmp/Jetty_0_0_0_0_9443_mcsdk.axis2.war____.xz4n3v/webapp/WEB-INF/services/mcService-server-7.0.0-SNAPSHOT.jar
2014-04-09 12:44:59,015 [main] INFO  org.apache.axis2.deployment.ServiceDeployer  - Deploying Web service: mcsdk10-server-7.0.0-SNAPSHOT.jar - file:/data01/avamar/var/mc/server_tmp/Jetty_0_0_0_0_9443_mcsdk.axis2.war____.xz4n3v/webapp/WEB-INF/services/mcsdk10-server-7.0.0-SNAPSHOT.jar

Cause

Hög Java-användning på Avamar Utility Node-noden kan göra att tömningar (säkerhetskopieringar) av Management Console-servern (MCS).

En ökning av konstant CPU-användning efter att portgenomsökningar skickar skräpfrågesträngar till MC-webbtjänsten via port 9443.

Därför är MCS inte tillgängligt för säkerhetskopieringsprocessen och kan göra att tömningen misslyckas.

 

Resolution

1. Kontrollera om en portskanner (t.ex. Nessus) genomsöker någon av Avamar-noderna. Inaktivera om möjligt portskanning till Avamar-verktygsnoden.

2. Logga in som administratör på Avamar-verktygsnoden och läs in nycklarna Avamar: Logga in på en Avamar-server och läs in olika nycklar.

3. Använd tangenten top kommando för att kontrollera om java har en hög CPU-användning (över 100 % är högt):

top

 

 

4. Kontrollera om några port 9443-meddelanden visas i axelloggen:

grep 9443 /usr/local/avamar/var/mc/server_log/axis2.log
2014-04-09 12:44:56,908 [main] INFO  org.apache.axis2.deployment.ServiceDeployer  - Deploying Web service: mcService-server-7.0.0-SNAPSHOT.jar - file:/data01/avamar/var/mc/server_tmp/Jetty_0_0_0_0_9443_mcsdk.axis2.war____.xz4n3v/webapp/WEB-INF/services/mcService-server-7.0.0-SNAPSHOT.jar
2014-04-09 12:44:59,015 [main] INFO  org.apache.axis2.deployment.ServiceDeployer  - Deploying Web service: mcsdk10-server-7.0.0-SNAPSHOT.jar - file:/data01/avamar/var/mc/server_tmp/Jetty_0_0_0_0_9443_mcsdk.axis2.war____.xz4n3v/webapp/WEB-INF/services/mcsdk10-server-7.0.0-SNAPSHOT.jar
 

5. Kontrollera när Java-processen startades:

ps -ef | grep java

 

    • Om datumet för java-processen matchar data från steg 4 (i det här exemplet 2014-04-09) kan processen vara i ett tillstånd som inte svarar
    • Om datumet för javaprocessen är nytt eller inte stämmer överens ska du sluta använda den här lösningen

6. Växla till root-privilegium:

su - 

 

 

7. Döda den kränkande javaprocessen:

a. Leta reda på java-process-ID (PID):

ps -ef | grep java
 

b. Döda processen.

kill -9 <PID>
 

8. Avsluta root-privilegiet:

exit
 

9. Stoppa och starta MCS med Avamar: Så här startar du om Management Control Server (MCS)

10. Kontrollera att MCS-tömningen nu fungerar och att inga "22402"-fel visas.

mcserver.sh --flush
 

11. Om felmeddelandena kvarstår kan du läsa Avamar – Symptomfel 22402 – Det gick inte att spara konsolserverdata till servern (lösningssökväg) för ytterligare felsökning.

Skapa en tjänstebegäran om du behöver ytterligare hjälp.

Επηρεαζόμενα προϊόντα

Avamar

Προϊόντα

Avamar
Ιδιότητες άρθρου
Article Number: 000163004
Article Type: Solution
Τελευταία τροποποίηση: 23 Σεπ 2025
Version:  8
Βρείτε απαντήσεις στις ερωτήσεις σας από άλλους χρήστες της Dell
Υπηρεσίες υποστήριξης
Ελέγξτε αν η συσκευή σας καλύπτεται από τις Υπηρεσίες υποστήριξης.