Data Protection Central (DPC) выдает ошибку 502 при доступе к пользовательскому интерфейсу после первоначальной установки

Summary: В этой статье базы знаний описывается устранение ошибок при входе в пользовательский интерфейс Data Protection Central (DPC) после первоначальной установки DPC.

Αυτό το άρθρο ισχύει για Αυτό το άρθρο δεν ισχύει για Αυτό το άρθρο δεν συνδέεται με κάποιο συγκεκριμένο προϊόν. Δεν προσδιορίζονται όλες οι εκδόσεις προϊόντων σε αυτό το άρθρο.

Symptoms

После установки DPC при попытке входа в пользовательский интерфейс DPC отображается ошибка HTTP 502.
Проверив сервисы DPC, найдите несколько сервисов в зарегистрированном состоянии.

В файле /var/log/dpc/elg/elg.log найдите ошибки, подобные следующей.

2021-02-16 15:35:57,340 ERROR main o.s.b.SpringApplication Application run failed
com.emc.clp.spi.UnavailableException: Unable to init ELG
...
Caused by: java.util.concurrent.ExecutionException: java.util.concurrent.CompletionException: java.lang.IllegalStateException: Could not create URI object: Illegal character in hostname at index 10: https://dp_central.lab.dell.com/pf-admin-api/v1/oauth/clients

Cause

Это вызвано недопустимым символом в имени хоста DPC.

 

Resolution

Чтобы решить эту проблему, повторно разверните DPC с именем хоста, содержащим только поддерживаемые символы.

В приведенном выше примере имя хоста — «dp_central.lab.dell.com». Символ подчеркивания «_» не поддерживается.
Имя хоста DPC поддерживает только следующие критерии.

  • Каждый элемент имени хоста должен содержать от 1 до 63 символов.
  • Полное имя хоста, включая точки, не может содержать более 253 символов.
  • Допустимыми символами являются буквы от a до z, цифры от 0 до 9 и дефис «-», имя хоста не может начинаться с дефиса «-».
  • Каждый элемент разделен точкой.

 

Επηρεαζόμενα προϊόντα

Data Protection Central
Ιδιότητες άρθρου
Article Number: 000183400
Article Type: Solution
Τελευταία τροποποίηση: 16 Ιαν 2026
Version:  5
Βρείτε απαντήσεις στις ερωτήσεις σας από άλλους χρήστες της Dell
Υπηρεσίες υποστήριξης
Ελέγξτε αν η συσκευή σας καλύπτεται από τις Υπηρεσίες υποστήριξης.