Data Protection Central (DPC) กําลังสร้างข้อผิดพลาด 502 ขณะเข้าถึง UI หลังจากการติดตั้งครั้งแรก

Summary: KB นี้ครอบคลุมวิธีการแก้ไขปัญหาด้วยการเข้าสู่ระบบ UI ของ Data Protection Central (DPC) หลังจากการติดตั้ง DPC ครั้งแรก

Αυτό το άρθρο ισχύει για Αυτό το άρθρο δεν ισχύει για Αυτό το άρθρο δεν συνδέεται με κάποιο συγκεκριμένο προϊόν. Δεν προσδιορίζονται όλες οι εκδόσεις προϊόντων σε αυτό το άρθρο.

Symptoms

หลังจากติดตั้ง DPC เมื่อพยายามเข้าสู่ระบบ DPC UI ได้รับข้อผิดพลาด HTTP 502
หลังจากตรวจสอบบริการ DPC แล้ว ให้ค้นหาบริการหลายอย่างในสถานะที่ยื่น

ในไฟล์ /var/log/dpc/elg/elg.log ให้ค้นหาข้อผิดพลาดที่คล้ายกับต่อไปนี้

2021-02-16 15:35:57,340 ERROR main o.s.b.SpringApplication Application run failed
com.emc.clp.spi.UnavailableException: Unable to init ELG
...
Caused by: java.util.concurrent.ExecutionException: java.util.concurrent.CompletionException: java.lang.IllegalStateException: Could not create URI object: Illegal character in hostname at index 10: https://dp_central.lab.dell.com/pf-admin-api/v1/oauth/clients

Cause

อักขระที่ผิดกฎหมายในชื่อโฮสต์ของ DPC ทําให้เกิดปัญหานี้

 

Resolution

เมื่อต้องการแก้ไขปัญหานี้ ให้ปรับใช้ DPC อีกครั้งด้วยชื่อโฮสต์ที่มีเฉพาะอักขระที่รองรับ

ในตัวอย่างด้านบน ชื่อโฮสต์คือ "dp_central.lab.dell.com" ขีดล่าง "_" ไม่ใช่อักขระที่รองรับ
ชื่อโฮสต์ DPC รองรับเกณฑ์ต่อไปนี้เท่านั้น

  • แต่ละองค์ประกอบของชื่อโฮสต์ต้องมีความยาวระหว่าง 1 ถึง 63 อักขระ
  • ชื่อโฮสต์ทั้งหมด รวมถึงจุดต้องมีความยาวไม่เกิน 253 อักขระ
  • อักขระที่ถูกต้องคือตัวอักษร a ถึง z ตัวเลข 0 ถึง 9 และยัติภังค์ "-" ชื่อโฮสต์ไม่สามารถขึ้นต้นด้วยยัติภังค์ "-"
  • แต่ละองค์ประกอบถูกคั่นด้วยจุด

 

Επηρεαζόμενα προϊόντα

Data Protection Central
Ιδιότητες άρθρου
Article Number: 000183400
Article Type: Solution
Τελευταία τροποποίηση: 16 Ιαν 2026
Version:  5
Βρείτε απαντήσεις στις ερωτήσεις σας από άλλους χρήστες της Dell
Υπηρεσίες υποστήριξης
Ελέγξτε αν η συσκευή σας καλύπτεται από τις Υπηρεσίες υποστήριξης.