Isilon : Erreur Impossible de trouver le fournisseur de disque lors de la réinitialisation

Summary: L’erreur « Impossible de trouver le fournisseur de disque » peut se produire lorsque le programme de création d’une nouvelle image ne parvient pas à trouver un fournisseur de données d’amorçage. ...

Αυτό το άρθρο ισχύει για Αυτό το άρθρο δεν ισχύει για Αυτό το άρθρο δεν συνδέεται με κάποιο συγκεκριμένο προϊόν. Δεν προσδιορίζονται όλες οι εκδόσεις προϊόντων σε αυτό το άρθρο.

Symptoms

Le message d’erreur « Cannot find disk provider » s’affiche pendant le processus de création d’une nouvelle image.

Cannot find disk provider
Traceback (most recent call last):
  File "/root/bin/flashdisk_reimage.py", line 2375, in 
    sys.exit(main(getargs()))
  File "/root/bin/flashdisk_reimage.py", line 2251, in main
    setup_psi(args)
  File "/root/bin/flashdisk_reimage.py", line 1703, in setup_psi
    setup_psi_backup_device(args)
  File "/root/bin/flashdisk_reimage.py", line 1763, in setup_psi_backup_device
    psi_backup_device.providers.init_short()
  File "/root/bin/flashdisk_reimage.py", line 1213, in init_short
    bootdisk.init_providers(wipe=False)
  File "/b/mnt/obj/b/mnt/src/amd64.amd64/isilon/lib/python/stage-3.8/usr/local/lib/python3.8/site-packages/isi/sys/bootdisk.py", line 729, in init_providers
  File "/b/mnt/obj/b/mnt/src/amd64.amd64/isilon/lib/python/stage-3.8/usr/local/lib/python3.8/site-packages/isi/sys/bootdisk.py", line 730, in 
IndexError: list index out of range

La commande permettant de confirmer le problème est la suivante : isi_bootstrap_devices -b, qui produit la sortie suivante :

isi-bsd# /usr/bin/isi_hwtools/isi_bootstrap_devices -b
name:
isi-bsd#

Cause

La cause de ce problème est un disque manquant dans le numéro de logement le plus élevé du traîneau A du nœud.

Resolution

Pour résoudre le problème, procédez comme suit :

  • Placez un disque dans le numéro de logement le plus élevé du traîneau A du nœud. Si le disque a été retiré en raison d’une panne, remplacez le disque défectueux avant de continuer.
  • Si vous disposez d’un disque dans le numéro de logement A le plus élevé, remplacez-le par un autre disque dans le traîneau. Une fois le traîneau réinstallé, relancez le processus de création d’une nouvelle image.

 

Attention : Si vous avez des doutes ou des inquiétudes concernant ces modifications, contactez le support Dell ou consultez leur site Web pour obtenir de l’aide.
Remarque : Soulevezla quincaillerie avec précaution pour éviter tout dommage.

Επηρεαζόμενα προϊόντα

Isilon Gen6, PowerScale A310, PowerScale A3100, PowerScale H710, PowerScale H7100
Ιδιότητες άρθρου
Article Number: 000359362
Article Type: Solution
Τελευταία τροποποίηση: 17 Οκτ 2025
Version:  1
Βρείτε απαντήσεις στις ερωτήσεις σας από άλλους χρήστες της Dell
Υπηρεσίες υποστήριξης
Ελέγξτε αν η συσκευή σας καλύπτεται από τις Υπηρεσίες υποστήριξης.