VxRail: 디스크를 교체한 후 VxRail 플러그인의 물리적 보기에 디스크 슬롯이 관리되지 않음으로 표시되고 드라이브 구성이 비어 있음

Summary: 디스크를 교체한 후 VxRail 플러그인의 물리적 보기에 디스크 슬롯이 관리되지 않음으로 표시되고 드라이브 구성이 비어 있음.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

디스크를 교체한 후 VxRail 플러그인의 물리적 보기에 디스크 슬롯이 관리되지 않고 드라이브 구성이 비어

있는 것으로 표시됩니다. 문제 1. VxRail 물리적 보기가 아닌 일반 VMware 프로세스를 사용하여 디스크를 교체하여 교체 디스크 장애를 해결합니다.
문제 2: VxRail 물리적 보기에 일련 번호가 올바르지 않거나 디스크가 누락된 디스크가 표시됩니다.
문제 3: 위의 문제를 해결한 후 물리적 보기에 디스크 슬롯이 관리되지 않음으로 표시되고 드라이브 구성이 비어 있는 것으로 표시됩니다.

Cause

지원되지 않는 방법으로 디스크를 교체했습니다. VxRail 플러그인을 항상 사용해야 합니다.
완전한 vxnode.config 파일에는 디스크 세그먼트, PSU 세그먼트, local_slot_claims 세그먼트, Disk_group_options 세그먼트 disk_group_type 세그먼트. 이 local_slot_claims 또는 disk_group_options 또는 둘 다 이 파일에 있어야 합니다. 그 중 어느 것도 종료되지 않으면 hardware-model-specs.json.

Resolution

루트 사용자로 VxRail Manager에서 아래 명령을 실행하여 ESXi 파일 vxnode.config를 새 디스크/PSU 일련 번호 및 슬롯 정보로 업데이트합니다. ESXi 호스트 이름과 <> ESXi 루트 암호를> 실제 값으로 바꿉니다.


<디스크 정보를 업데이트하려면 다음을 수행합니다.

curl -X POST --unix-socket /var/lib/vxrail/nginx/socket/nginx.sock http://127.0.0.1/rest/vxm/internal/do/v1/hosts/baseline-update -H 'Content-Type: application/json' -d '[{"hostname":"<ESXi hostname>", "username":"root","password":"<ESXi root password>", "update_disk":true}]'


PSU 정보를 업데이트하려면 다음을 수행합니다.

curl -X POST --unix-socket /var/lib/vxrail/nginx/socket/nginx.sock http://127.0.0.1/rest/vxm/internal/do/v1/hosts/baseline-update -H 'Content-Type: application/json' -d '[{"hostname":"<ESXi hostname>", "username":"root","password":"<ESXi root password>", "update_psu":true}]'

VxRail Manager에서 서비스 재시작

systemctl restart vmware-marvin

systemctl restart runjars

 

참고:
  • curl 명령을 실행할 때 오류가 발생하면 iDRAC에서 전원 공급 장치가 나열되어 있는지 확인합니다. 그렇지 않은 경우(TSR 보고서에 전원 공급 장치가 없다고 표시됨) iDRAC를 재부팅하거나 재설정하고 이후에 전원 공급 장치가 나열되는지 확인합니다(다음 TSR 보고서에도 전원 공급 장치가 표시되어야 함).
  • baseline-update curl 명령이 200 성공을 반환하지만 vxnode.config 파일이 업데이트되지 않으면 VxRail Manager에서 short.term.log 검토하여 무엇이 잘못되었는지 파악합니다. 노드의 플랫폼 서비스가 실행되고 있지 않기 원인일 수 있습니다. iDRAC를 재설정하고 플랫폼 서비스를 재시작하여 서비스를 다시 불러올 수 있는지 확인한 다음 baseline-update 명령을 다시 실행할 수 있습니다.

Affected Products

VxRail Appliance Family, VxRail Appliance Series, VxRail G Series Nodes, VxRail D Series Nodes, VxRail D560, VxRail D560F, VxRail E Series Nodes, VxRail E560, VxRail E560F, VxRail E560N, VxRail E660, VxRail E660F, VxRail E660N, VxRail E665 , VxRail E665F, VxRail E665N, VxRail G560, VxRail G560F, VxRail P Series Nodes, VxRail P570, VxRail P570 VCF, VxRail P570F, VxRail P580N, VxRail P670F, VxRail P670N, VxRail P675F, VxRail P675N, VxRail S Series Nodes, VxRail S570, VxRail S670, VxRail V Series Nodes, VxRail V570, VxRail V570F, VXRAIL V670F, VxRail VD-4510C, VxRail VD-4520C, VxRail VP-760, VxRail VP-7625, VxRail VS-760 ...
Article Properties
Article Number: 000196355
Article Type: Solution
Last Modified: 07 Nov 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.