PowerStore: SAS topology change may lead to node reboot

Summary: A change in the SAS topology (such as LCC disconnect, cable disconnect, several drives removed and more) may under rare instances lead to a node reboot. This issue only affects appliances attached to a SAS enclosure (aka Tabasco). ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Node reboots and automatically recovers. In some scenarios, both nodes may reboot and lead to service disruption.

Cause

The SAS driver has different processes for handling a single drive removal vs multiple drives removal (bulk removal). When handling bulk removal (such as LCC/cable issue), the driver must abort all I/O for each drive. A software issue exists where, during the cleanup process, there is a race condition with another process that attempts to also abort I/O that no longer exists. This leads to a node reboot. This is a rare race condition.

Resolution

The issue is fixed in PowerStoreOS 3.5.
 

Workaround

Contact Technical Support support for assistance.

Affected Products

PowerStore Expansion Enclosure
Article Properties
Article Number: 000210883
Article Type: Solution
Last Modified: 31 Jul 2023
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.