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Windows 10: New SSD not detected in Disk Management

Summary: The following article is about a newly installed Solid State Disk (SSD) not being detected in Disk management. This is on the Windows 10 operating system with Storage Spaces set up.

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Article Content


Symptoms

Newly installed SSD seen in BIOS and Device Manager, but is not detected in Disk Management?

 

Have you recently fitted an aftermarket or third party SSD? Is it recognized in the BIOS and Device Manager, but it is not detected in Disk Management?

The issue may be resolved by going to Manage Storage Spaces and removing the drive from the storage pool that has taken ownership of the drive.

Note: This solution depends on you having Windows 10 installed on your computer. You must have had Storage Spaces setup prior to your new SSD having been installed. If you do not have storage spaces configured on your computer, this guide does not help you. Check out the following link for further help with storage drives:
 
HDD Icon  Source additional information about Hard Drives and solid state drives on our support page.

Cause

This section is not applicable for this article.

Resolution

Steps to removing a drive from a Windows 10 Storage Pool

 

Manage Storage Spaces

(Figure.1 Manage Storage Spaces)

If you created a pool in Windows 10 or upgraded an existing pool, then you can remove a drive from it. The data stored on that drive is moved to other drives in the pool, and you can use the drive for some other purpose:

  1. Open the start menu and type Storage Spaces, then select Storage Spaces from the list of results that appear

  2. Select change settings > physical drives to see all the drives currently in your pool

  3. Locate the drive that you want to remove from the pool

  4. Select prepare for removal > prepare for removal. Leave the computer plugged in until the drive is ready to be removed

  5. If the computer keeps going into sleep, you can prevent this by typing Power & sleep in the Start Menu, and then select power and sleep settings. Change when plugged in, computer goes to sleep after, to Never

  6. When the drive is showing as ready to remove, select remove > remove drive. Now, you can enter the Disk Management console and see if the computer now detects the drive.

  7. You may want to delete the Storage Pool if the drive is still not detected

Note: If the drive has been fitted for a while, you may run into problems when you try to prepare the drive for removal. You need enough free space in the pool to store all the data from the drive you want to remove. You can add a new drive to the pool that is as large as the drive you plan to remove and then try again. You can find out more about Storage Spaces on the following link to the Microsoft Support page:

Article Properties


Affected Product

G Series, Inspiron, Latitude, Vostro, XPS, Fixed Workstations

Last Published Date

05 Jan 2024

Version

5

Article Type

Solution