VMware: vRealize Aria Operations for logs reported errors during new objects creation or deletion

Summary: The VMware Aria operations for logs have an error during object creation or object deletion. The operations were finally successful though. The version that triggered this problem is on 8.16.0 but may not be limited to this version only. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

When creating an object such as a chart on the existing dashboard or a new dashboard, the customer would see the create failed. If deleting some charts the delete would fail, but after a while it could be seen that the new dashboard or the new chart in the existing dashboard.

Chart operation failure

When creating a field, the web graphic user interface would trigger a "Cassandra timeout error message" but after a while the customer could see that the field was created.

Field creation timeout

Logs:

[2024-04-22 08:53:04.372+0000] ["CassandraClientParallelExecutor-thread-4152"/10.159.197.195 WARN] [com.vmware.loginsight.cassandra.CassandraClient] [Exception during asynchronous execution (3875612721059898833): Statement:(select guid, count from spock_cluster_counts where guid in ? and bucket = ? limit 1000000) java.util.concurrent.ExecutionException: com.datastax.oss.driver.api.core.servererrors.ReadTimeoutException: Cassandra timeout during read query at consistency QUORUM (2 responses were required but only 1 replica responded). In case this was generated during read repair, the consistency level is not representative of the actual consistency.]
java.util.concurrent.ExecutionException: com.datastax.oss.driver.api.core.servererrors.ReadTimeoutException: Cassandra timeout during read query at consistency QUORUM (2 responses were required but only 1 replica responded). In case this was generated during read repair, the consistency level is not representative of the actual consistency.

Even modifying the configuration file /storage/core/loginsight/cidata/cassandra/config/cassandra.yaml and increase the value write_request_timeout to 3000millisecond and perform the restart of aria operations for logs service the problem persists.
 

Cause

  • The Cassandra cluster has some issues.
  • When they are trying to create a field under Aria Operations for logs they are getting timeout errors.
  • This would involve a certain LI API for managing fields.
     

Resolution

To resolve this issue, restart all the appliance nodes in the Aria Operations for logs cluster.

Affected Products

OpenManage Management Pack for VMware Aria Operations, VMware ESXi 7.x, VMware ESXi 8.x

Products

OpenManage Management Pack for vRealize Operations Manager - Current Version
Article Properties
Article Number: 000224734
Article Type: Solution
Last Modified: 16 May 2025
Version:  3
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