PowerFlex 4.X: Gateway Resource Displays PowerFlex Unreachable

Summary: The PowerFlex Gateway resource displays an alert about the PowerFlex system is unreachable.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The backend PowerFlex system is still on 3.x software and was imported into the PowerFlex Manager 4.x system.

 

Impact

Unable to perform a successful PowerFlex Gateway upgrade.

 

Cause

In PowerFlex Manager, there are two gateway pods responsible for load-balancing requests. While the backend system is on version 3.x, the gateway uses a token for authentication with the MDM. However, the authentication token is stored on only one of the gateways. Therefore, when multiple consecutive calls are made, the load balancing feature may direct some calls to the gateway without the login token, causing these calls to fail. This failure results in the gateway resource alerting that the PowerFlex system is unreachable.

 

Resolution

Drop the ReplicaSet of the PowerFlex gateways down to a single gateway:

  1. SSH to any of the PowerFlex Management Platform hosts

  2. Drop the replicas down to 1:

    kubectl scale sts block-legacy-gateway -n powerflex --replicas=1
  3. Perform the Gateway upgrade. This upgrades the system to 4.x where MTLS is used and this problem is not observed.

  4. Once the backend PowerFlex system is upgraded to 4.x, adjust the replica set back to 2 for the Gateway:

    kubectl scale sts block-legacy-gateway -n powerflex --replicas=2

 

Impacted Version

PowerFlex Manager 4.x

Fixed In Version

PowerFlex Manager 4.6.1

 

Affected Products

PowerFlex rack, PowerFlex Appliance, PowerFlex custom node, PowerFlex Software
Article Properties
Article Number: 000226554
Article Type: Solution
Last Modified: 01 Jan 2026
Version:  2
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