CloudLink: Interoperability between vSphere 8.0 and CloudLink

Summary: vSphere 8.0 is supported by CloudLink 8.0 and later versions. It is not supported by CloudLink7.1.x or previous versions. Customers using CloudLink as a Key Provider upgrading vSphere to 8.0 must first upgrade CloudLink to 8.0 or a later version. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

When a vSphere environment is being upgraded to version 8.0, CloudLink 7.1.x (or a previous version) as a Key Provider is not supported.
Although vCenter can be upgraded to 8.0 and still show connectivity to CloudLink 7.1.x, the ESXi hosts will be locked after the upgrade. CloudLink must be upgraded to version 8.0 or later to address these issues. 

The recommended process is to upgrade CloudLink to version 8.0 or later first, then upgrade the vSphere environment to version 8.0.

Cause

ESXi hosts at version 8.0 do not work with CloudLink 7.1.x. This is because CloudLink 7.1.x does not support the TLS 1.3 protocol that the ESXi hosts. CloudLink 8.0.x and later versions support this protocol.

Resolution

To resolve this issue, upgrade CloudLink to 8.0 or later versions.
Check the upgrade path by reviewing the CloudLink 8.0 Release Notes.

Affected Products

CloudLink
Article Properties
Article Number: 000215933
Article Type: Solution
Last Modified: 16 Apr 2026
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.