OneFS: Notificação de evento: O nó atingiu 95% ou mais de capacidade utilizada no file system raiz
Summary: Em nós mais antigos do Isilon IQ X e da série NL, o diretório raiz (/) tem um tamanho máximo de 500 MB e mostra 95% ou mais de capacidade utilizada. Isso ocorre mesmo quando não há arquivos de usuário ou pacotes de firmware adicionais instalados. Os nós mais recentes têm diretórios raiz com um tamanho de 1 GB e normalmente mostram 49% de capacidade utilizada. ...
Symptoms
Evento
Node reached 95% used capacity on the root file system.
-Ou-
The root partition is near capacity.
Event ID: 100010003
Cause
Detalhes
Esse evento indica que a partição raiz em um ou mais nós está se aproximando da capacidade máxima.
Esse evento pode ocorrer por vários motivos. Os dois motivos mais comuns são:
- Um usuário moveu um arquivo para um diretório raiz não especificado em vez de para o diretório /ifs .
- O firmware do nó foi atualizado, mas o pacote de firmware não foi removido.
Resolution
Resposta
Solucione a causa desse alerta usando um ou mais dos procedimentos a seguir.
IMPORTANTE!
Não remova nem instale nenhum patch de software enquanto a partição raiz estiver cheia ou perto de sua capacidade. A tentativa de instalar/remover um patch enquanto a partição raiz está cheia pode causar falha no processo de instalação ou remoção do patch. Se o processo de instalação ou remoção falhar em um cluster com uma partição raiz completa, isso pode impedir a reversão para a configuração anterior do sistema. Essa situação pode deixar o cluster em um estado instável ou inacessível.
Para obter mais informações sobre como manter espaço livre suficiente em um cluster Isilon, consulte o Guia de gerenciamento de capacidade do cluster no site de suporte on-line da Dell.
Fase 1: Remova os arquivos que não pertencem ao diretório raiz (/).
- Examine a mensagem de alerta para determinar o file system afetado. A mensagem identifica o cluster e os nós (por número de nó) que geraram o alerta. A mensagem também identifica o file system afetado como um dos seguintes: ifs, var, crash ou root.
- No nó que gerou o alerta, execute o seguinte comando para listar todos os arquivos no diretório raiz com mais de 5 MB:
find -x / -type f -size +10000 -exec ls -lh {} \; | awk '{ print $9 ": " $5 }'
Um resultado parecido com este será exibido:
/boot/kernel.amd64/efs.ko: 10M /usr/libexec/cc1: 6.6M /usr/libexec/cc1plus: 7.2M /usr/libexec/cc1obj: 6.6M /usr/local/lib/libxerces-c-3.1.so: 5.6M /usr/local/lib/libxerces-c.so: 5.6M /usr/local/sbin/nmbd: 9.9M /usr/local/connectemc/connectemc: 15M /usr/local/aspera/sbin/asperacentral: 5.0M
O exemplo de resultado acima lista os arquivos que normalmente são encontrados no diretório raiz. Esses arquivos não devem ser removidos.
- Na saída, procure todos os arquivos que normalmente não pertencem ao diretório raiz. Por exemplo, um arquivo de instalação do OneFS, um conjunto de logs ou um arquivo criado pelo usuário. (Consulte o exemplo de resultado na etapa anterior para arquivos que pertencem ao diretório raiz e não devem ser removidos.)
- Remova os arquivos ou mova-os para o diretório /ifs. Se você não tiver certeza sobre quais arquivos remover, entre em contato com o suporte técnico do Isilon para obter assistência.
Execute o seguinte comando para confirmar se o diretório raiz (/) está abaixo do limite de alerta:
isi_for_array -s 'df -h /'
Um resultado parecido com este será exibido:
Filesystem Size Used Avail Capacity Mounted on /dev/imdd0a 496M 445M 11M 94% /
- Apague todos os alertas existentes:
isi event bulk --resolved=true (OneFS 8.0 or newer) -or- isi events cancel all (OneFS 7.x or older)
- Se o espaço não for recuperado após a remoção de arquivos grandes, procure um processo que ainda tenha o arquivo aberto. Esse processo deve ser interrompido para fechar o identificador de arquivo que mantém o espaço. Consulte Como usar o comando fstat para listar os arquivos abertos em um nó, artigo 322712.
- Se o problema não for resolvido, vá para a fase 2.
Fase 2: Remova os pacotes de firmware do nó do Isilon.
As instruções incluídas nos pacotes de firmware de nó do Isilon incluem uma etapa para remover o pacote de firmware após a instalação do firmware. Se essa etapa não for concluída, o diretório raiz poderá exceder a capacidade.
- Execute o seguinte comando para confirmar se um pacote de firmware está instalado no cluster:
isi upgrade patches list (OneFS 8.0 or newer) -or- isi pkg info (OneFS 7.x or older)
Um resultado parecido com este será exibido:
IsiFw_Package_v8.2: Isilon firmware packages contain firmware images that may be used to update certain devices in your cluster. To install this firmware package, use the 'isi pkg install <package-filename>' command. Note that the act of installing the package will not automatically update your devices. Once installed, please refer to 'isi firmware --help' or the firmware section in 'man isi' for more information.
- Remova o pacote de upgrade de firmware, em que <package-filename> ou <patch> é o nome do nome do arquivo do firmware-package:
isi upgrade patches uninstall --patch=<patch> (OneFS 8.0 or newer) -or- isi pkg delete <package-filename> (OneFS 7.x or older)
- Execute o seguinte comando para confirmar se o diretório raiz está abaixo do limite de alerta:
isi_for_array -s 'df -h /'
Um resultado parecido com este será exibido:
mycluster-1: Filesystem Size Used Avail Capacity Mounted on mycluster-1: /dev/imdd0a 496M 445M 11M 97% / mycluster-2: Filesystem Size Used Avail Capacity Mounted on mycluster-2: /dev/imdd0a 496M 445M 12M 97% / mycluster-3: Filesystem Size Used Avail Capacity Mounted on mycluster-3: /dev/imdd0a 496M 445M 12M 97% /
- Apague todos os alertas existentes:
isi event bulk --resolved=true (OneFS 8.0 or newer) -or- isi events cancel all (OneFS 7.x or older)
- Se o problema não for resolvido, vá para a Fase 3.
Fase 3: Entre em contato com o suporte técnico do Isilon
Se não for possível determinar por que o diretório raiz (/) está próximo ou acima da capacidade, faça o seguinte:
- Colete logs do sistema executando o seguinte comando:
isi_gather_info -s 'ls -lhat /' -s 'du -axh / | sort -rn' -s 'du -xhd1 /'
Os registros são carregados automaticamente no suporte técnico da Dell.
- Entre em contato com o suporte técnico da Dell para obter ajuda na solução do problema.