VxRail: VxRail Manager VM CPU Usage Error in vCenter Due to Xvnc Processes

Summary: This KB explains a workaround for the VxRail Manager Virtual Machine (VM) showing 100% (or high) CPU usage in vCenter, due to Xvnc processes.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The VxRail Manager virtual machine shows 100% (or high) CPU usage in vCenter, due to Xvnc processes.

To identify these processes:
-Log into a CLI session to the VxRail Manager VM
-Run the below command:
# top 
-Look for processes that show "Xvnc" in the owner column that are using a high percent of CPU.

Cause

The Xnvc processes are caused by Nessus scans. Probing on a regular TCP port but not completing a TCP connection is a sort of "TCP half-open" or "SYN flood" attack.
Reference:
     https://en.wikipedia.org/wiki/TCP_half-openThis hyperlink is taking you to a website outside of Dell Technologies.
     https://en.wikipedia.org/wiki/SYN_floodThis hyperlink is taking you to a website outside of Dell Technologies.

Resolution

The workaround for this issue is to reboot the VxRail Manager VM, which kills the Xvnx processes. If the customer wants the Xvnc processes to stop populating, they can bypass the VxRail Manager when they perform Nessus scans.

Additional Information

A Virtual Machine's CPU capacity is capped to the VM's hardware specification.  For any reason that a VM is running 100%, it is capped to its assigned CPU cycles and will not impact other VMs or hosts. <<== This is "VM isolation"

Affected Products

VxRail, VxRail Appliance Series, VxRail Software
Article Properties
Article Number: 000036008
Article Type: Solution
Last Modified: 01 Apr 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.