NetWorker: NMC Server database Backup Failing With "no matching devices for save of client"
Summary: The NetWorker Management Console (NMC) Server database backup fails with 'no matching devices for save of client.' The workflow sets the correct pool, and the device is mounted.
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Symptoms
The NetWorker Management Console (NMC) Database backup is failing with the following error:
74920:save: Step (4 of 6) for PID-10128: Contacting the NetWorker server through the nsrd process to obtain a handle to the target media device through the nsrmmd process for the save set '/nsr/nmc/nmcdb_stage/pgdata'. 174908:save: Saving the backup data in the pool 'backup_pool'. 175297:save: Unable to set up the direct save with server 'networker_server': no matching devices for save of client `nmc_server'; check storage nodes, devices or pools.
Cause
The error indicates that it is detecting no matching devices for save of client NMC_Server.
The NMC Server backup workflow defines the pool used for backup; however, the default override option is "Client can override"
NOTE: This means that any settings applied in the NMC server's client resource overrides settings defined in the backup action.
The NMC server's client resource has a different pool defined.

NOTE: View -> Diagnostic Mode must be enabled in the NMC to see the Pool dropdown in the client resource.
The pool listed in the client resource is not mounted or misconfigured.
The error 'Check storage nodes, devices, and pools' is general and may appear for other reasons. If the NMC server client properties lack a pool setting and this failure occurs, see the Additional Info section for troubleshooting steps.
Resolution
Remove the pool specification from the NMC server's client resource:
The pool specified in the backup action is used instead.
Additional Information
Affected Products
NetWorkerProducts
NetWorker, NetWorker Management ConsoleArticle Properties
Article Number: 000039833
Article Type: Solution
Last Modified: 18 Jul 2025
Version: 4
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