Avamar - Oracle 備份或還原失敗,並出現錯誤「聯絡 avoracle 時發生錯誤」

Summary: Avamar - Oracle 備份或還原失敗,並出現錯誤「聯絡 avoracle 時發生錯誤」

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

未觀察到任何變化。備份/還原可能會間歇性失敗。

您可能會看到使用 Avamar GUI 進行 Avamar 備份或還原失敗,並顯示 ORA-19511 錯誤 -
"error contacting avoracle":

channel c0: ORA-19870: error while restoring backup piece TEST1_qgtscam1_1_1
ORA-19507: failed to retrieve sequential file, handle="TEST1_qgtscam1_1_1", parms=""
ORA-27029: skgfrtrv: sbtrestore returned error
ORA-19511: Error received from media manager layer, error text:
   sbtrestore: error contacting avoracle
在 Oracle sbtio 記錄中,avoralce 在 1 分鐘後逾時:
SBT-387809 03/19/19 15:47:00 args:libid avoracle
SBT-387809 03/19/19 15:47:00 args:param TEST1_qgtscam1_1_1
SBT-387809 03/19/19 15:47:00 args:code2str startavtar
.
.
SBT-387372 03/19/19 15:47:41 args:libseq 4
SBT-399866 03/19/19 15:47:41 sbtrestore: The avtar command is: /opt/avamar/bin/avtar "--ctlusessl=false" "--cacheprefix=TEST1_c0" "--sysdir=/opt/avamar/etc" "--bindir=/opt/avamar/bin" "--vardir=/opt/avamar/var/clientlogs" "--logfile=/opt/avamar/var/clientlogs/MOD-1552974230429-1002-Oracle_RMAN-avtar0.log" "--ctlcallport=13140" --ctlinterface="1054-MOD-1552974230429#2"
SBT-399866 03/19/19 15:47:41 sbtrestore: tokened_cmd = /opt/avamar/bin/avtar
SBT-387372 03/19/19 15:47:44 sbtclose2: start
SBT-387809 03/19/19 15:48:01 couldnot recv length
SBT-387809 03/19/19 15:48:01 msg_len 0
SBT-387856 03/19/19 15:48:01 sizeof len 4
SBT-387856 03/19/19 15:48:01 error 7501: sbtrestore: error contacting avoracle

Cause

當 Oracle 伺服器處於忙碌狀態,且沒有足夠的可用資源時,可能會發生此問題。媒體管理程式庫有一個固定的時間間隔,可在備份和還原期間逾時之前,從 avoracle 中聽到。雖然在大多數情況下,默認時間間隔就足夠了,但在某些情況下,它太短,備份或還原會失敗。

Resolution

引入了新的標誌「libobk_timeout」來控制libobk_avamar庫中的超時。這需要以分鐘為單位的時間值。若未提供值 0 或未提供任何值,則預設為 1 分鐘。
可以通過以下方式設定此值:

 1) 在avoracle.cmd:  
 --libobk_timeout=10

 2) 從 MC GUI:
   備份命令列選項> 更多 -> 輸入屬性為 [avoracle]libobk_timeout -> 輸入值 = 10以上會將libobk_timeout設定為 10 分鐘。如果收到相同的錯誤,請增加該值並再次檢查。   

注意:需要修補程式才能識別新旗標。請根據作業系統類型和 Avamar 用戶端版本而定,開啟支援要求,並據此要求下列修補程式:
 
  • Avamar 用戶端 7.2.101-32、作業系統 RHEL 7 x64 或 Solaris x64 ---修正程式301835
  • Avamar 用戶端 7.4.101-58,作業系統 RHEL 6 - x64 ---- hotfix 294157
  • Avamar 用戶端 7.5.101-101,作業系統HP_UX ia64 --- hotfix 299433
  • Avamar 用戶端 7.5.101-101,作業系統 RHEL 7.6 - x64 --- hotfix 308164

Affected Products

Avamar
Article Properties
Article Number: 000053946
Article Type: Solution
Last Modified: 29 Jul 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.