Avamar: el respaldo o la restauración de Oracle fallan con el error "error al comunicarse con avoracle"

Summary: Avamar: el respaldo o la restauración de Oracle fallan con el error "error al comunicarse con avoracle"

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

No se observa ningún cambio. El respaldo o la restauración podrían fallar de forma intermitente. 

Es posible que vea que el respaldo o la restauración de Avamar mediante la GUI de Avamar fallan con el error ORA-19511:
"error contacting avoracle":

channel c0: ORA-19870: error while restoring backup piece TEST1_qgtscam1_1_1
ORA-19507: failed to retrieve sequential file, handle="TEST1_qgtscam1_1_1", parms=""
ORA-27029: skgfrtrv: sbtrestore returned error
ORA-19511: Error received from media manager layer, error text:
   sbtrestore: error contacting avoracle
En el registro sbtio de Oracle, se agotó el tiempo de espera de avoralce después de 1 minuto:
SBT-387809 03/19/19 15:47:00 args:libid avoracle
SBT-387809 03/19/19 15:47:00 args:param TEST1_qgtscam1_1_1
SBT-387809 03/19/19 15:47:00 args:code2str startavtar
.
.
SBT-387372 03/19/19 15:47:41 args:libseq 4
SBT-399866 03/19/19 15:47:41 sbtrestore: The avtar command is: /opt/avamar/bin/avtar "--ctlusessl=false" "--cacheprefix=TEST1_c0" "--sysdir=/opt/avamar/etc" "--bindir=/opt/avamar/bin" "--vardir=/opt/avamar/var/clientlogs" "--logfile=/opt/avamar/var/clientlogs/MOD-1552974230429-1002-Oracle_RMAN-avtar0.log" "--ctlcallport=13140" --ctlinterface="1054-MOD-1552974230429#2"
SBT-399866 03/19/19 15:47:41 sbtrestore: tokened_cmd = /opt/avamar/bin/avtar
SBT-387372 03/19/19 15:47:44 sbtclose2: start
SBT-387809 03/19/19 15:48:01 couldnot recv length
SBT-387809 03/19/19 15:48:01 msg_len 0
SBT-387856 03/19/19 15:48:01 sizeof len 4
SBT-387856 03/19/19 15:48:01 error 7501: sbtrestore: error contacting avoracle

Cause

Este problema puede ocurrir cuando el servidor de Oracle está ocupado y no tiene suficientes recursos disponibles. La biblioteca de administración de medios tiene un intervalo de tiempo fijo para recibir noticias de avoracle antes de que se agote el tiempo de espera durante el respaldo y las restauraciones. Si bien para la mayoría de los casos el intervalo de tiempo predeterminado es suficiente, en algunos casos es demasiado corto y el respaldo o la restauración fallan.

Resolution

Se introdujo una nueva marca "libobk_timeout" para controlar el tiempo de espera agotado en la biblioteca de libobk_avamar. Toma el valor del tiempo en minutos. Si se proporciona un valor de 0 o no se proporciona ningún valor, el valor predeterminado es 1 minuto.
Este valor se puede configurar de las siguientes maneras:

 1) En avoracle.cmd:  
 --libobk_timeout=10

 2) Desde la GUI de MC:
   Opciones de la línea de comandos de respaldo:> Más -> Ingrese el atributo como [avoracle]libobk_timeout -> Ingrese un valor = 10Lo anterior establecerá el libobk_timeout a 10 minutos. Si recibe el mismo error, aumente el valor y vuelva a comprobarlo.   

Nota: Se necesita una revisión para reconocer la nueva marca. Según el tipo de SO y la versión del cliente Avamar, abra una solicitud de soporte y solicite las siguientes revisiones:
 
  • Avamar Client 7.2.101-32, SO RHEL 7 x64 o Solaris x64 --- 301835 de revisión
  • Avamar Client 7.4.101-58, SO RHEL 6-x64 ---- revisión 294157
  • Avamar Client 7.5.101-101, SO HP_UX ia64 --- revisión 299433
  • Avamar Client 7.5.101-101, SO RHEL 7.6 - x64 --- revisión 308164

Affected Products

Avamar
Article Properties
Article Number: 000053946
Article Type: Solution
Last Modified: 29 Jul 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.