Avamar - Back-up of herstel van Oracle mislukt met foutmelding "error contact avoracle"
Summary: Avamar - Back-up of herstel van Oracle mislukt met foutmelding "error contact avoracle"
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Er is geen verandering waargenomen. De back-up/het herstel kan af en toe mislukken.
U ziet mogelijk dat Avamar back-up of herstel met behulp van de Avamar GUI mislukt met ORA-19511 fout -
U ziet mogelijk dat Avamar back-up of herstel met behulp van de Avamar GUI mislukt met ORA-19511 fout -
"error contacting avoracle": channel c0: ORA-19870: error while restoring backup piece TEST1_qgtscam1_1_1 ORA-19507: failed to retrieve sequential file, handle="TEST1_qgtscam1_1_1", parms="" ORA-27029: skgfrtrv: sbtrestore returned error ORA-19511: Error received from media manager layer, error text: sbtrestore: error contacting avoracleIn het logboek van de Oracle sbtio is er na 1 minuut een time-out opgetreden:
SBT-387809 03/19/19 15:47:00 args:libid avoracle SBT-387809 03/19/19 15:47:00 args:param TEST1_qgtscam1_1_1 SBT-387809 03/19/19 15:47:00 args:code2str startavtar . . SBT-387372 03/19/19 15:47:41 args:libseq 4 SBT-399866 03/19/19 15:47:41 sbtrestore: The avtar command is: /opt/avamar/bin/avtar "--ctlusessl=false" "--cacheprefix=TEST1_c0" "--sysdir=/opt/avamar/etc" "--bindir=/opt/avamar/bin" "--vardir=/opt/avamar/var/clientlogs" "--logfile=/opt/avamar/var/clientlogs/MOD-1552974230429-1002-Oracle_RMAN-avtar0.log" "--ctlcallport=13140" --ctlinterface="1054-MOD-1552974230429#2" SBT-399866 03/19/19 15:47:41 sbtrestore: tokened_cmd = /opt/avamar/bin/avtar SBT-387372 03/19/19 15:47:44 sbtclose2: start SBT-387809 03/19/19 15:48:01 couldnot recv length SBT-387809 03/19/19 15:48:01 msg_len 0 SBT-387856 03/19/19 15:48:01 sizeof len 4 SBT-387856 03/19/19 15:48:01 error 7501: sbtrestore: error contacting avoracle
Cause
Dit probleem kan zich voordoen wanneer de Oracle-server bezet is en er niet genoeg bron beschikbaar is. De mediabeheerbibliotheek heeft een vast tijdsinterval om van de gebruiker te horen voordat er een time-out optreedt tijdens het maken van back-ups en herstelbewerkingen. Hoewel het standaard tijdsinterval in de meeste gevallen voldoende is, is het in sommige gevallen te kort en mislukt de back-up of het herstel.
Resolution
Er is een nieuwe vlag "libobk_timeout" geïntroduceerd om de time-out in de libobk_avamar bibliotheek te beheren. Het kost de waarde van tijd in minuten. Als een waarde van 0 of geen waarde wordt opgegeven, wordt deze standaard ingesteld op 1 minuut.
Deze waarde kan op de volgende manieren worden ingesteld:
1) In avoracle.cmd:
--libobk_timeout=10
2) Van MC GUI: Back-up opdrachtregelopties -> More -> Enter Attribute as [avoracle]libobk_timeout -> Enter value=10Met het bovenstaande wordt de libobk_timeout ingesteld op 10 minuten. Als u dezelfde foutmelding krijgt, verhoogt u de waarde en controleert u opnieuw. Opmerking: Er is een hotfix nodig om de nieuwe vlag te herkennen. Open een supportaanvraag, afhankelijk van het type besturingssysteem en de Avamar clientversie, en vraag dienovereenkomstig om de volgende hotfixes:
- Avamar client 7.2.101-32, besturingssysteem RHEL 7 x64 of Solaris x64 ---hotfix 301835
- Avamar client 7.4.101-58, besturingssysteem RHEL 6 - x64 ---- hotfix 294157
- Avamar client 7.5.101-101, OS HP_UX ia64 --- hotfix 299433
- Avamar client 7.5.101-101, besturingssysteem RHEL 7.6 - x64 --- hotfix 308164
Affected Products
AvamarArticle Properties
Article Number: 000053946
Article Type: Solution
Last Modified: 29 Jul 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.