Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.
Some article numbers may have changed. If this isn't what you're looking for, try searching all articles. Search articles

VxRail: Host can't communicate with one or more other nodes in the vSAN enabled cluster alert

Summary: The KB explains how to restart the vsanmgmtd which is commonly known as the vSAN Health Service or vSAN Management Service.

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms



Multiple alerts appear on hosts indicating vSAN configuration issue or communication issue between the host and other hosts in the cluster like:
  • Host is in a vSAN cluster but does not have vSAN service enabled.
  • vSAN network is not configured.
  • Host cannot communicate with one or more other nodes in the vSAN enabled cluster.

Cause

While vsanmgmtd is unresponsive or has crashed, the host can no longer report certain vSAN statistics to vCenter. This leads to vCenter reporting false or improper information for one or more hosts, causing many regular management operations to time out or fail.

Resolution

To resolve these issue restart the vSAN management health service on the host:
  1. SSH to host using the root account.
  2. /etc/init.d/vsanmgmtd restart.

Article Properties


Affected Product

VxRail Appliance Family

Product

VxRail Appliance Family

Last Published Date

21 Apr 2022

Version

3

Article Type

Solution