Symptoms
Multiple alerts appear on hosts indicating vSAN configuration issue or communication issue between the host and other hosts in the cluster like:
- Host is in a vSAN cluster but does not have vSAN service enabled.
- vSAN network is not configured.
- Host cannot communicate with one or more other nodes in the vSAN enabled cluster.
Cause
While vsanmgmtd is unresponsive or has crashed, the host can no longer report certain vSAN statistics to vCenter. This leads to vCenter reporting false or improper information for one or more hosts, causing many regular management operations to time out or fail.
Resolution
To resolve these issue restart the vSAN management health service on the host:
- SSH to host using the root account.
- /etc/init.d/vsanmgmtd restart.