Keyboard Working Intermittently After Windows 10 Update

Summary: This article provides the information about the keyboard working intermittently after a Windows 10 update.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Keyboard Not Working

Some Dell computer Users have reported that their keyboard was not working after Windows 10 Update if Logitech Set Point software is installed. Microsoft Office or other applications may also stop responding on keyboard input.

After updating to Windows 10, the integrated or USB keyboard may work in some applications such as notepad but not others such as Microsoft Office or Microsoft Edge browser.

Cause

No cause information is available.

Resolution

Update the Logitech Set Point Software

As with other Windows 10 driver issues, updating the application to the latest version of the driver (in the Set Point case, Version 6.67.82 This hyperlink is taking you to a website outside of Dell Technologies.) resolves the issue.

Dell Technologies recommends updating the BIOS and all drivers for the original operating system and any third-party devices PRIOR to the installation of the Windows 10 update.

Note: If you have already upgraded to Windows 10, then roll back to the previous version of Windows, then apply the fix and upgrade again.

Back to Top

Article Properties
Article Number: 000145127
Article Type: Solution
Last Modified: 22 Aug 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.