Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Uso de registros de Windows para solucionar problemas inalámbricos que solo se ven en las ubicaciones de los clientes

Summary: En este artículo, se proporciona información sobre la captura de un registro de seguimiento de eventos (ETL). Incluye el ETL y otros archivos que pueden ayudar a Dell a solucionar problemas inalámbricos que solo se ven en los sitios del cliente. ...

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

El sistema operativo Windows tiene numerosos registros que pueden ser beneficiosos cuando se analiza el problema inalámbrico en la ubicación del cliente. Especialmente cuando esos problemas no se pueden replicar en otros entornos de red.

Cause

Localización, creación y exportación de los registros

Registros que ya existen de pruebas anteriores:

  1. Antes de encontrar la computadora, es posible que se hayan creado registros que pueden ser valiosos. El WLANAutoconfig.log archivo en el Visor de eventos (si aún no está compilado en un archivo CAB) se puede encontrar y guardar manualmente en el Visor de eventos de Windows:
    1. En el Visor de eventos, vaya a Aplicaciones y registros de servicio.
    2. Vaya a Microsoft.
    3. Vaya a Windows.
    4. A continuación, abra la Wlan-autoconfig carpeta.
  2. El NETSH siguiente script genera salidas a la carpeta C:\wlogs :

WLAN-autoconfig Registro de diagnóstico

Puede habilitar el registro de WLAN-autoconfig diagnóstico en el sistema sometido a prueba (SUT) antes de futuras pruebas. Esto podría ayudar con algunos mensajes de registro más detallados. Utilice las siguientes instrucciones.

Para habilitar el registro de diagnóstico:

  1. Abra el Visor de eventos y vaya a:
    1. Aplicaciones y registros de servicios
    2. A continuación , Microsoft
    3. A continuación, Windows
    4. Entonces Wlan-Autoconfig
  2. Haga clic con el botón secundario en la Wlan-Autoconfig carpeta.
  3. A continuación, seleccione Ver.
  4. Mostrar los registros analíticos y de depuración .
  5. El registro de diagnóstico aparece en la carpeta Autoconfig.
  6. Haga clic con el botón secundario en el registro de diagnóstico y seleccione: Habilitar el registro

Resolution

NOTA: Hay una advertencia. Este registro se debe guardar manualmente desde el visor de eventos para poder compartirlo con Dell después de las pruebas. Es posible que no se encuentre automáticamente en la NETSH carpeta cab de salida.

Netsh texto del script como referencia: (Copie el texto que aparece a continuación y péguelo en un bloc de notas y guarde el archivo como ETL.BAT)

@echo off

rem PASTE THIS SCRIPT INTO NOTEPAD AND SAVE AS A .BAT FILE. RT CLICK THE FILE AND RUN AS ADMINISTRATOR.

rem DO NOT CREATE DIRECTORY IF IT ALREADY EXISTS
if exist c:\wlogs goto SKIPMKDIR
mkdir c:\wlogs
:SKIPMKDIR

rem BEGIN TRACE
netsh ras set tracing * enable

rem BUNDY, I WOULD LIKE TO DYNAMICALLY GENERATE THE FILENAME wlan001.etl TO AVOID WRITING OVER PREVIOUS LOGS
SET file1=1
IF EXIST c:\wlogs\wlan%file1%.etl GOTO nextlog
netsh trace start scenario=wlan tracefile=c:\wlogs\wlan1.etl capture=yes persistent=yes maxsize=250 report=yes
filemode=append
GOTO filedone
:nextlog
SET /A "file1+=1" IF EXIST c:\wlogs\wlan%file1%.etl GOTO nextlog
netsh trace start scenario=wlan tracefile=c:\wlogs\wlan%file1%.etl capture=yes persistent=yes maxsize=250 report=yes
filemode=append

:filedone
rem DISPLAY PROMPT TO PRESS ANY KEY TO STOP THE CAPTURE
set /p =Press any key to stop the capture. < nul
pause > nul

rem STOP TRACE
netsh trace stop

rem DISPLAY RESULTS AND PROMPT TO HIT ANY KEY BEFORE ENDING
pause

Article Properties


Affected Product

Desktops & All-in-Ones, Laptops

Last Published Date

10 Oct 2023

Version

5

Article Type

Solution