NVP-vProxy: Die VM verliert die Verbindung während des Snapshot-Entfernungsvorgangs.

Summary: Während des Schritts zum Entfernen von Snapshots eines vProxy-Jobs verliert die Quell-VM vorübergehend die Konnektivität.

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Symptoms

Das vProxy-Backupsitzungsprotokoll zeigt an, wann Snapshot-Anforderungen gestellt werden:

YYYY/MM/DD HH:MM:SS TRACE: [NW_BUILD] Sending remove snapshot request to Snapshot Manager ...
YYYY/MM/DD HH:MM:SS TRACE: [NW_BUILD] Sending remove snapshot request to Snapshot Manager ...
YYYY/MM/DD HH:MM:SS INFO: [NW_BUILD] Remove snapshot request accepted by Snapshot Manager.
YYYY/MM/DD HH:MM:SS INFO: [NW_BUILD] Remove snapshot request accepted by Snapshot Manager.
HINWEIS: Die Sitzungsprotokolle finden Sie auf dem vProxy unter /opt/emc/vproxy/runtime/logs/vbackupd/ oder /opt/emc/vproxy/runtime/logs/recycle/vbackupd/


Die vProxy-vbackupd-snapmgr.log zeigt möglicherweise einen Fehler an, z. B.:

YYYY/MM/DD HH:MM:SS INFO: Found virtual machine "VM-NAME" with MORef "vm-###".
YYYY/MM/DD HH:MM:SS NOTICE: Virtual machine "VM-NAME" requires consolidation of its virtual disks.
YYYY/MM/DD HH:MM:SS ERROR: Failed to complete consolidation of virtual disks for "VM-NAME" (vm-###): Unable to access file since it is locked
YYYY/MM/DD HH:MM:SS WARN: Failed to consolidate virtual disks of virtual machine "VM-NAME" (vm-###): Failed to complete consolidation of virtual disks for "VM-NAME" (vm-###): Unable to access file since it is locked.
YYYY/MM/DD HH:MM:SS WARN: Failed to consolidate virtual disks of virtual machine "VM-NAME" (vm-###): Failed to complete consolidation of virtual disks for "VM-NAME" (vm-###): Unable to access file since it is locked.
YYYY/MM/DD HH:MM:SS NOTICE: Snapshot "snapshot-###" of virtual machine "VM-NAME" (vm-###) was removed.
HINWEIS: Die vbackupd-snapmgr.log finden Sie unter:  /opt/emc/vproxy/runtime/logs/vbackupd/ oder /opt/emc/vproxy/runtime/logs/recycle/daemon/


Ereignisprotokolle auf dem VM-Betriebssystem zeigen möglicherweise einen Fehler an, z. B.:

The mirroring connection to "TCP://VM-NAME:5022" has timed out for database "out" after 10 seconds without a response. Check the service and network connections"
Event ID: 1479.

Das vmware.log der VM (zu finden im VMware-Datenspeicherordner der VM) enthält möglicherweise zusätzliche Informationen über den Snapshot-Löschvorgang.

Cause

NetWorker/vProxy entfernt nicht den Snapshot selbst. Das VMware vCenter steuert die Erstellung, das Management und das Löschen von VM-Snapshots. NetWorker initiiert ein Backup, indem es eine Anforderung an VMware sendet, einen Snapshot zu erstellen. Am Ende wird eine Anforderung zum Löschen des Snapshots gesendet.

Das Entfernen von Snapshots reduziert die VM-IOPS-Anzahl (Input/Output Per Second). Dies geschieht aufgrund zusätzlicher VMFS-Speichersperren (Virtual Machine File System) durch vermehrte Metadatenaktualisierungen und zusätzlicher IOP-Last während des Entfernungsvorgangs. Wenn die IOP-Last des Zielspeichers über 30 bis 40 % liegt, kann sie durch das Entfernen von Snapshots auf über 80 % erhöht werden. Diese Spitze führt häufig zu Latenz, die sich negativ auf die Anwendungsleistung auswirkt.

NVP-vProxy: Troubleshooting von VMware-Snapshot-Problemen während NetWorker-Backups.

Resolution

Isolationstests:

Um das Problem auf das spezifische VMware-Snapshot-Entfernungsereignis einzugrenzen, führen Sie die folgenden Schritte aus:
 
WARNUNG: Führen Sie die folgenden Schritte zu einem Zeitpunkt aus, zu dem die Konnektivität zur VM nicht sensibel ist, z. B. außerhalb der Spitzenzeiten.
  1. Melden Sie sich bei vCenter Server oder vSphere Client an.
  2. Erstellen Sie einen Snapshot auf der betreffenden VM.
  3. Belassen Sie den Snapshot auf der VM für eine Zeitspanne, die ein vProxy-Job auf der VM ausgeführt wird.
  4. Starten Sie einen Ping-Befehl für die IP-Adresse/den Hostnamen der VM.
Linux:
ping -D VM_IP
Windows (PowerShell): 
ping -t VM_IP | Foreach{"{0} - {1}" -f (Get-Date),$_}
Beide oben genannten Befehle versehen den Ping-Zeitstempel. 
  1. Entfernen Sie den Snapshot.
  2. Beobachten Sie die VM während des Entfernens des Snapshots.
Wenn bei der Durchführung des obigen Tests dasselbe Verbindungsproblem wie während des vProxy-Backupjobs beobachtet wird, liegt das Problem wahrscheinlich in der VMware-Umgebung vor. Öffnen Sie ein Supportticket beim VMware-Support, um weitere Untersuchungen durchzuführen.

Für VMs, die in einem NFSv3-Datenspeicher gespeichert sind:

Wenn Sie VMs sichern, die auf einem NFSv3-Datenspeicher gespeichert sind, und Verbindungsprobleme feststellen, finden Sie weitere Informationen unter VMware Wissensdatenbank-Artikel: https://kb.vmware.com/s/article/2010953Dieser Hyperlink führt Sie zu einer Website außerhalb von Dell Technologies.

VMware meldet dieses spezifische Problem als behoben, wenn VMware ESXi-Hosts verwendet werden, die 8.0u2b (oder neuer) sind.Die

folgenden Optionen sind für Lösungen verfügbar, die NFSv3 für ESXi-Versionen vor 8.0u2b verwenden. Eine der folgenden Optionen muss in Betracht gezogen werden.
  • Stellen Sie eine NVP-vProxy-Appliance auf demselben ESXi-Host wie die VMs bereit, die bearbeitet werden.
  • Erwägen Sie die Verwendung des NFSv4-Protokolls zum Mounten von NFS-Datenspeichern. 
HINWEIS: Lesen Sie vor der Implementierung von NFS 4.1 den Abschnitt NFS-Protokolle und vSphere-LösungenKonzepte und Vorgänge für NFS-Datenspeicher in vSphere-Umgebungen.Dieser Hyperlink führt Sie zu einer Website außerhalb von Dell Technologies.NFS 4.1 verwendet andere Sperrmechanismen als NFSv3 – siehe Sperrmechanismen.
  • Konfigurieren Sie die vProxy-Appliances, die diese VMs sichern, so, dass sie NBD anstelle von HotAdd verwenden. Die Verwendung von Hot Add, wann immer möglich, wird bevorzugt, da dies in der Regel eine bessere Leistung als NBD bietet. Eine hohe NBD-Last kann sich negativ auf VMware-Managementnetzwerke auswirken. Diese Option sollte nur dann durchgeführt werden, wenn die anderen genannten Optionen nicht möglich sind. 
vProxys können nur für Backups mit NBD konfiguriert werden. Über die NetWorker Management Console (NMC) –> Geräte –> VMware-Proxys:
Einstellungen für NBD-Sitzungen
HINWEIS: Wenn Sie "Hot Add" auf 0 setzen, wird der Transportmodus "Hot Add" deaktiviert. 

Additional Information

Zusätzliche Fehlerbehebung:

  • Überprüfen Sie die VM auf Snapshots, während kein Job ausgeführt wird, und entfernen Sie alle gefundenen Snapshots.
  • Suchen Sie nach verwaisten Snapshots auf der VM. 
  • Reduzieren Sie die Anzahl der gleichzeitigen VM-Backups, die auf diesem Datenspeicher/Host ausgeführt werden. Empfehlungen zur Performance und Skalierbarkeit finden Sie im NetWorker VMware Integration Guide. https://www.dell.com/support/home/product-support/product/networker/docs
  • Wenn die CPU-Ressourcen der VM während der Snapshot-Konsolidierung stark ansteigen, sollten Sie in Erwägung ziehen, die CPU-Reservierung für diese VM zu erhöhen.
  • Verschieben Sie die VM auf einen Host mit mehr verfügbaren Ressourcen.
  • Wenn es sich bei der VM um die vCenter Server Appliances handelt, finden Sie weitere Informationen unter Best Practices für vCenter Server-Backup und -Wiederherstellung im NetWorker VMware-Integrationshandbuch: https://www.dell.com/support/home/product-support/product/networker/docs


VMware KB-1002836Dieser Hyperlink führt Sie zu einer Website außerhalb von Dell Technologies. | Durch das Entfernen von Snapshots kann eine virtuelle Maschine für lange Zeit angehalten werden.

Überprüfen Sie das VMware vCenter-Support-Bundle und stellen Sie sicher, dass Sie die ESXi-Systemprotokolle für die ESXi-Systeme erfassen, auf denen VMs gehostet werden, auf denen dieses Symptom beobachtet wurde. \var\run\log\vmkernel.log des ESXi-Hosts kann während der Snapshot-Vorgänge Probleme mit der Speicherlatenz anzeigen:

YYYY-MM-DDTHH:mm:SS cpu10:2098132)WARNING: ScsiDeviceIO: 1498: Device naa.############# performance has deteriorated. I/O latency increased from average value of 1429 microseconds to 29874 microseconds.

Der Storage-Anbieter muss mit der weiteren Untersuchung beauftragt werden.

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000167629
Article Type: Solution
Last Modified: 10 Nov 2025
Version:  8
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