VPLEX: SymptomCode 0x8a4830dc, UPS-lasteffekten lägre än förväntat
Summary: Den här artikeln handlar om de steg du ska ta för att bekräfta om det rapporterade call home är en verklig händelse eller en falsk positiv händelse och kan ignoreras. Den här artikeln gäller alla VPLEX-plattformar. ...
Symptoms
Ett lägre strömproblem än förväntat rapporterades för UPS:en som anges i CDATA i call home-meddelandet, vilket visas i exemplet nedan.
Endast kluster med två motorer och fyra motorer innehåller avbrottsfri strömförsörjning (UPS).
På VS2 är UPS-A till för batteribackup av Fibre-Channel-switch-A och hanteringsservern, och UPS-B för Fibre-Channel-switch-B.
På VS6 är UPS-A och B endast för Infini-Band (IB)-switcharna.
Exempel på uppringning som skickas för det här numret:
VS2:
SymptomCode : 0x8a4830dc
Category : Status
Severity : Warning
Status : Warning
Component : DIRECTOR
ComponentID : director-1-2-B << component reporting the issue
SubComponent : ZPEM
CallHome : Yes
FirstTime : 20xx-05-07T01:45:58.048Z
LastTime : 20xx-05-07T01:45:58.048Z
Count : x
CDATA[ups@UPS-B: PartNo 078-000-052/SerialNo QS1303140800 /RevNo 1XE1 :UPS load power is lower than expected [Versions:MS{x.x.x.x}, Director{x.x.x.x.x}]
RCA: The fibre channel switch and/or management server are not plugged in to the UPS.
I det här exemplet på uppringning hemutdata rapporterar problemet att UPS-belastningseffekten är lägre än förväntat på UPS-B i kluster-1.
Cause
Orsaken till att dessa uppringningshem rapporteras för lägre belastningseffekt än förväntat kan vara följande:
VS2:
För UPS-A
Hanteringsservern och/eller den interna rackmonterade Fibre Channel-switchen A kan inte ses av UPS:en.
För UPS-B
För den interna rackmonterade Fibre Channel-switchen kan inte ses av UPS:en.
VS6:
För UPS-A
Den interna rackmonterade Infini-Band-omkopplaren (IB) A en eller båda strömanslutningarna ses inte av UPS:en.
För UPS-B
För den interna rackmonterade Infini-Band-omkopplaren (IB) B ses inte en eller båda strömanslutningarna av UPS:en.
Resolution
Permanent korrigering:
Dell VPLEX-tekniker undersöker för närvarande det här problemet. När en korrigering är tillgänglig kommer den här artikeln att uppdateras.
Syftet med den här artikeln är att verifiera tillståndet för den UPS som rapporteras för "lägre effektnivåer än förväntat".
För att förstå hur du avgör vilken UPS som rapporteras för det här problemet och från vilket kluster kan du titta på ComponentID i call home-meddelandet som visas i avsnittet Problem ovan. I exemplet med call home-meddelande visas "director-1-2-B" rapporterade problemet. Det första värdet som anges är "1", det här är cluster-id, så i det här exemplet cluster-1. Eftersom rapporten kom från B-chefen, director-1-2-B, betyder det att det är UPS-B som problemet rapporterades för. CDATA talar också om för dig vilken UPS call home-rapporten var för, "ups@UPS-B". "UPS:en" är alltid ansluten till motor 2 på alla kluster.
Director-1-2-B
\ \ \------------ Detta talar om för dig att det är UPS-B (UPS-A är anslutna till "A"-styrenheterna)
\ \-------------- Detta säger att det är regissören är i motor 2.
\--------------- Det betyder att det är kluster-1.
Så här kontrollerar du om det här problemet är verkligt eller falskt positivt:
VS2:
- Kontrollera att båda Fibre Channel-switchens strömkablar är anslutna till rätt UPS och att UPS:erna är anslutna till varje strömfördelningsenhet (PDU) som finns på rackets monteringsskenor.
- Om händelsen rapporteras för UPS-A, kontrollera att strömkablarna för hanteringsservern och FC COM SWITCH A (ovanför hanteringsservern) är anslutna till UPS-A.
- Om händelsen rapporteras för UPS-B, kontrollera att FC COM SWITCH B:s strömkabel är ansluten till UPS-B.
- Kontrollera om strömkablarna från FC COM-switcharna och hanteringsservern sitter löst.
- Kontrollera att seriekablarna från varje UPS är ordentligt fastsatta.
- Se lämpligt serie- och strömkopplingsschema för konfiguration som bifogas den här artikeln.
VS6:
- Kontrollera att båda Infini-Band (IB) switchens strömkablar är anslutna till lämplig UPS och att UPS:erna är anslutna till varje PDS-enhet.
- Om händelsen rapporteras för UPS-A, kontrollera att strömkablarna för Infini-Band-switch A är anslutna till UPS-A.
- Om händelsen rapporteras för UPS-B, kontrollera att strömkablarna för Infini-Band-switch B är anslutna till UPS-B.
- Kontrollera om det finns lösa strömkablar från IB-switcharna.
- Kontrollera att seriekablarna från varje UPS är ordentligt fastsatta.
- Se lämpligt serie- och strömkopplingsschema för konfiguration som bifogas den här artikeln.
För att kontrollera om UPS:en har återgått till ett felfritt tillstånd används kluster-1 i exemplen nedan:
-
Logga in på hanteringsservern för VPLEX-klustret som call home rapporterades från
Exempel på utdata:
login as: service Using keyboard-interactive authentication. Password: Last login: Day Month Date HH:MM:SS Year from x.x.x.x < IP Address the login is from service@ManagementServer:~>
-
Öppna sedan VPlexcli med samma inloggningsuppgifter som används för åtkomst till hanteringsservern
Samplingsutdata på en VPLEX VS2 som kör pre-6.x, för 6.x-versioner krävs inte en andra inloggning för att komma åt VPlexcli:
service@ ManagementServer:~> vplexcli Trying ::1... Connected to localhost. Escape character is '^]'. Enter User Name: service Password: Creating logfile:/var/log/VPlex/cli/session.log_service_localhost_Logfile_T24531_YYYYMMDDHHMMSS VPlexcli:/>
-
Ändra katalog (cd) till UPS-kontexten och lista ut UPS:ens
Exempel på utdata:
VPlexcli:/> cd /clusters/cluster-1/uninterruptible-power-supplies VPlexcli:/clusters/cluster-1/uninterruptible-power-supplies> ll Name ------- ups-2-a ups-2-b
-
Bläddra till den UPS-kontextnivå som call home-aviseringen gällde för och lista detaljerna. I det här exemplet om du tittar tillbaka på exempelmeddelandet för call home i avsnittet Problem och tittar på CDATA. Du ser ups@UPS-B, och om du tittar ovanför detta på "ComponentID" ser du "director-1-2-B". Den första siffran anger klustret, i det här fallet är det "1" som anger kluster-1. Gå till cluster-1 och gå sedan nedåt till kontexten "uniterruptible-power-supplies" och titta sedan på ups-2-b enligt nedan.
Exempel på utdata:
VPlexcli:/clusters/cluster-1/uninterruptible-power-supplies> cd ups-2-b VPlexcli:/clusters/cluster-1/uninterruptible-power-supplies/ups-2-b> ll
VS2:
Name Value ------------------------ ------------- battery-replacement-date 03/23/10 < date battery was installed in the UPS, if more than 3 years old the UPS must be replaced battery-status fully-charged << check this value battery-time-remaining 5min operational-status online << check this value part-number 078-000-052 << note the part number of the UPS revision-number 1XE1 serial-number <UPS Serial Number>
VS6:
Name Value ------------------------ ------------- battery-replacement-date 09/21/15 battery-status fully-charged << check this value battery-time-remaining 5min operational-status online << check this value part-number 078-000-079 << note the part number of the UPS revision-number FFF serial-number <UPS Serial Number>
Sök efter en falskt positiv händelse:
-
Om batteristatus visas som fulladdad och driftstatus visas som online kan problemet ignoreras. Aviseringen var troligen en falsk positiv avisering. Problemet kan ha rapporterats under ett batteritest/en laddningscykel som utförs av UPS:en. Detta kan bekräftas genom att kontrollera firmwareloggarna med datumet nära datumet för call home, vilket kan noteras från call home-meddelandeexemplet som listas i avsnittet Problem, leta efter "LastTime"-datum och sedan göra en sökning på UPS-"serienumret" som anges i CDATA för call home i firmwareloggen.
Exempel på batteritest/laddningscykel för UPS som rapporterats i loggar för fast programvara:
VS2:
Rapporten om belastningseffekten lägre än förväntat:128.221.253.38/xmmg/log:5988:W/"154559":109:<4>20xx/11/04 10:36:26.54: ZPEM/220 ups@UPS-B: PartNo 078-000-052 /SerialNo QS1322142106 /RevNo 1XE1 : UPS load power is lower than expected.
Rapporten om att UPS:arna är felaktiga:
128.221.253.38/xmmg/log:5988:W/"154559":110:<3>20xx/11/04 10:36:26.54: ZPEM/471 ups@UPS-B: PartNo 078-000-052 /SerialNo QS1322142106 /RevNo 1XE1 : The operational state of the specified fru is Faulted.
Rapporten om ups-batteriet som laddas:
128.221.252.38/xmmg/log:5988:W/"154559":111:<4>20xx/11/04 10:36:38.40: ZPEM/211 ups@UPS-B: PartNo 078-000-052 /SerialNo QS1322142106 /RevNo 1XE1 : battery-status is Charging <<< this tells us the UPS is in battery test or charging mode
Rapporten om de ups som nu fungerar, ses inte längre som felaktiga:
128.221.252.70/xmmg/log:5988:W/"154559":112:<6>20xx/11/04 10:36:38.40: ZPEM/87 ups@UPS-B: PartNo 078-000-052 /SerialNo QS1322142106 /RevNo 1XE1 : The operational state of the specified fru has changed to Working. << this says the battery test/charging phase is over and the UPS is back on AC
Kontrollera om UPS-enheten verkligen är defekt:
-
Om "batteristatus" visar laddning och "driftstatus" visas online, kontrollera igen om cirka 5 minuter eftersom batteritest-/laddningsläget fortfarande kan pågå. Om "batteristatus" efter fem minuter visar laddning och "driftstatus" visar offline eller fel, kan detta indikera ett problem med UPS:en och du måste byta ut den felaktiga UPS:en.
-
För UPS-bytet måste du kontakta VPLEX-supporten och meddela dem dina resultat och att UPS-enheten måste bytas ut. Nämn den här artikeln.
Så här kontaktar du Dell VPLEX-supporten via chatt:
För att nå support börjar du med att gå till Dell Support.com. På sidan Välkommen till Dells support står VPLEX-serien, VPLEX VS2 eller VPLEX VS6 längst upp. Bläddra sedan nedåt och titta på höger sida och leta efter "Kontakta teknisk support". Om du har ett aktivt servicekontrakt loggar du in. Om du inte har ett aktivt serviceavtal kan du kontakta en lokal Dell-representant för att få hjälp. När du har det aktiva servicekontraktet har loggat in bör du se sidan med tekniska problem, och här ser du alternativen för hur du kontaktar VPLEX-supporten.
Additional Information
- VS2 FC COM-switchar, hanteringsserver och PDU:er
- VS6 Infini-Band (IB) switchar och PDU:er