Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Article Number: 000173290


PowerPath Management Appliance 2.4: Unable to login to PPMA via GUI or SSH as root

Article Content


Symptoms

Log in to PPMA as Root

Unable to login to PPMA via GUI or SSH as root.

While logging to PPMA GUI, it throws the error "The username or password is incorrect":

kA23a000000GJcdCAG_3_0

While doing an SSH to PPMA, it throws the error " Access Denied":

kA23a000000GJcdCAG_3_1

But was able to login to PPMA VM Console:
kA23a000000GJcdCAG_3_2

Cause

PermitRootLogin was set to NO which is the reason why the login to PPMA as root was failing:

kA23a000000GJcdCAG_1_0

**In this case, Root login was disabled since the Customer had some hardening process (security reasons) going on and they had domain logon enabled.**

Please note, the default output looks something like this:

pp-xxxxx # grep -i rootlogin /etc/ssh/sshd_config
#PermitRootLogin yes
# the setting of "PermitRootLogin without-password".

Resolution

Since it was not possible to login with root user, it would be recommended to login as another user with root privileges which will also allow to monitor PPMA.
Following are the ways to create a User with root privileges:

1. Login to PPMA console with root user and create a new user with root privilege.
 
2. SSH login to domain user and create a local user with root privilege.

After this, you should be able to login to PPMA with another user with root privileges.

Article Properties


Last Published Date

20 Nov 2020

Version

2

Article Type

Solution