Avamar: Hyper-V-sikkerhetskopiering mislykkes med feilen 'Windows Structured Exception ACCESS_VIOLATION'

Summary: Kunnskapsbaseartikkel (KB) som inneholder detaljerte instruksjoner for bruk av Hyper-V-hurtigreparasjoner i riktig rekkefølge.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Sikkerhetskopieringer av Hyper-V-klynger kan mislykkes eller fullføres med følgende feil:

2021-01-13 01:18:07 avhypervvss Error <42448>: 1 remote client(s) failed to complete operation on the remote file targets
2021-01-13 01:18:07 avhypervvss Info <43400>: Attempting to commit checkpoint for targets with backup success...
2021-01-13 01:18:07 avhypervvss Info <43409>: Attempting to convert backup CheckPoint to ReferrencePoint.
2021-01-13 01:18:07 avhypervvss Error <43712>: Failed to backup Virtual Machine 'PS001 <VM GUID>'
2021-01-13 01:18:07 avhypervvss Error <43712>: Failed to backup Virtual Machine 'CN001 <VM GUID>'
2021/01/13-09:18:45.98200 [hypervvss_assist]  ERROR: <41036> threadimpl::runthread() - Windows structured exception ACCESS_VIOLATION in threadID 12828
2021-01-13 01:18:45 avhypervvss Warning <41036>: threadimpl::runthread() - Windows structured exception ACCESS_VIOLATION in threadID 12828
2021/01/13-09:18:46.07500 [hypervvss_assist]  ERROR: <41037> 0: OPENSSL_Applink()+0x277287 [0xa1683e87]

Cause

Informasjonen i avhypervvss.exe Hurtigreparasjonsbinærfiler er ikke riktig brukt på klyngenodene. Hvis de ikke brukes i riktig rekkefølge, fører resultatet til periodiske sikkerhetskopieringsfeil.

Resolution

Avregistrer, avinstaller og installer Avamar-klientprogramvaren og Hyper-V-plugin-modulen på nytt på alle klyngenoder. Bruk deretter de nyeste oppdateringene, avhengig av Avamar-versjonen.

Før du distribuerer hurtigreparasjonsbinærfilene, må du kontrollere at det ikke er noen aktive sikkerhetskopieringer eller gjenopprettinger som kjører på klienter. Lagre flaggene og konfigurasjonssettet i avhypervvss.cmd og avatar.cmd.

  1. Kjør veiviseren for konfigurasjon av Avamar-klynge, og avregistrer klyngeklienten.
  2. Avinstaller Avamar Hyper-V-plugin-modulen på alle nodene i klyngen.
  3. Avinstaller Avamar Windows-klienten på alle nodene i klyngen.
  4. Start noden på nytt hvis plugin-modulen Hyper-V Granular Level Recovery (GLR) er konfigurert på noen av nodene.
  5. Rydd opp i eventuelle foreldede VM-grupper på alle nodene i klyngen. Engasjer DELL-kundestøtte om nødvendig.
  6. Installer Avamar Hyper-V-plugin-programvareversjon 19.10.100-135 på alle nodene i klyngen og på alle nodene i klyngen.
    1. Gå inn i services.msc -konsollen på hver node, og stopp tjenesten "DELL Avamar Plug-in Service for Windows" på hver node.
    2. Gi nytt navn til originalen winclustersvc.exe Å winclustersvc-ORIG.exe.
    3. Gi nytt navn til originalen winclustersvc.tlb Å winclustersvc-ORIG.tlb
    4. Gi nytt navn til originalen avhypervvss.exe Å avhypervvss-ORIG.exe
    5. Kopier de nye HF-binærfilene avhypervvss.exe, winclustersvc.exeog winclustersvc.tlb til "bin"-mappen på alle noder.
    6. Start tjenesten "DELL Avamar Plug-in Service for Windows" på nytt på alle klyngenodene.
    7. Bekreft at versjonen er riktig. Kjør følgende kommando:
      avhypervvss.exe --version

      Utdataene skal se omtrent slik ut:

      Version:     19.10.100-135_HF338820
  7. Kjør veiviseren for konfigurasjon av Avamar-klynge, og konfigurer klyngeklienten.
  8. Sett tilbake flagg og konfigurasjon i avhypervvss.cmd og avtar.cmd og kjøre sikkerhetskopier.


For Hyper-V RCT-sikkerhetskopier, konfigurasjon av "shared storagepath parameter" er nødvendig fra og med v19.4 og nyere. Bruk følgende KB-artikkel med instruksjoner for konfigurasjon og installasjon av de nyeste hurtigreparasjonene for disse nyere Avamar-versjonene:

KB Avamar Hyper-V VSS-plugin-modul: Konfigurering og installasjon av de nyeste kumulative HF-ene for 19.4 og nyere – 

Affected Products

Avamar, Avamar Plug-in for Hyper-V VSS
Article Properties
Article Number: 000181941
Article Type: Solution
Last Modified: 26 Feb 2026
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.