Avamar: Hyper-V Yedeklemesi "Windows Yapılandırılmış Özel Durum ACCESS_VIOLATION" Hatasıyla Başarısız Oluyor

Summary: Hyper-V düzeltmelerini doğru sırada uygulamak için ayrıntılı yönergeler sağlayan Knowledge Base (KB) makalesi.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Hyper-V küme yedeklemeleri başarısız olabilir veya aşağıdaki hatalarla tamamlanabilir:

2021-01-13 01:18:07 avhypervvss Error <42448>: 1 remote client(s) failed to complete operation on the remote file targets
2021-01-13 01:18:07 avhypervvss Info <43400>: Attempting to commit checkpoint for targets with backup success...
2021-01-13 01:18:07 avhypervvss Info <43409>: Attempting to convert backup CheckPoint to ReferrencePoint.
2021-01-13 01:18:07 avhypervvss Error <43712>: Failed to backup Virtual Machine 'PS001 <VM GUID>'
2021-01-13 01:18:07 avhypervvss Error <43712>: Failed to backup Virtual Machine 'CN001 <VM GUID>'
2021/01/13-09:18:45.98200 [hypervvss_assist]  ERROR: <41036> threadimpl::runthread() - Windows structured exception ACCESS_VIOLATION in threadID 12828
2021-01-13 01:18:45 avhypervvss Warning <41036>: threadimpl::runthread() - Windows structured exception ACCESS_VIOLATION in threadID 12828
2021/01/13-09:18:46.07500 [hypervvss_assist]  ERROR: <41037> 0: OPENSSL_Applink()+0x277287 [0xa1683e87]

Cause

Komutta avhypervvss.exe Düzeltme ikili dosyaları küme düğümlerine düzgün şekilde uygulanmadı. Doğru sırada uygulanmazlarsa sonuç aralıklı yedekleme hatalarına yol açar.

Resolution

Avamar istemci yazılımının ve Hyper-V eklentisinin kaydını silin, kaldırın ve tüm küme düğümlerinde Hyper-V eklentisini yeniden yükleyin. Ardından Avamar sürümüne bağlı olarak en son yamaları uygulayın.

Düzeltme ikili dosyalarını dağıtmadan önce istemcilerde çalışan etkin yedekleme veya geri yükleme olmadığından emin olun. avhypervvss.cmd ve avatar.cmd'da ayarlanan bayrakları ve yapılandırmayı kaydedin.

  1. Avamar küme yapılandırma sihirbazını çalıştırın ve küme istemcisinin kaydını silin.
  2. Avamar Hyper-V eklentisini kümenin tüm düğümlerinden kaldırın.
  3. Avamar Windows istemcisini kümenin tüm düğümlerinden kaldırın.
  4. Hyper-V Granular Level Recovery (GLR) eklentisi düğümlerden herhangi birinde yapılandırılmışsa düğümü yeniden başlatın.
  5. Varsa kümenin tüm düğümlerindeki eski vmgroup'ları temizleyin. Gerekirse DELL desteği ile iletişime geçin.
  6. Kümenin tüm düğümlerine ve kümenin tüm düğümlerine Avamar Hyper-V eklenti yazılımı sürümü 19.10.100-135'i yükleyin.
    1. İçeri gir services.msc konsolunu her düğümde yapılandırın ve her düğümde "Windows için DELL Avamar Plug-in Service" hizmetini durdurun.
    2. Orijinali yeniden adlandırma winclustersvc.exe özniteliğinin değerini winclustersvc-ORIG.exe.
    3. Orijinali yeniden adlandırma winclustersvc.tlb özniteliğinin değerini winclustersvc-ORIG.tlb
    4. Orijinali yeniden adlandırma avhypervvss.exe özniteliğinin değerini avhypervvss-ORIG.exe
    5. Yeni HF ikili dosyalarını kopyalayın avhypervvss.exe, winclustersvc.exeve winclustersvc.tlb tüm düğümlerde "bin" klasörüne.
    6. Tüm küme düğümlerinde "Windows için DELL Avamar Plug-in Service" hizmetini yeniden başlatın.
    7. Sürümün doğru olduğundan emin olun. Aşağıdaki komutu çalıştırın:
      avhypervvss.exe --version

      Çıktı aşağıdakine benzer görünmelidir:

      Version:     19.10.100-135_HF338820
  7. Avamar küme yapılandırma sihirbazını çalıştırın ve küme istemcisini yapılandırın.
  8. Geri bayrakları ve yapılandırmayı ayarlayın avhypervvss.cmd ve avtar.cmd ve yedeklemeleri çalıştırın.


Hyper-V RCT yedeklemeleri için "shared storagepath parametre" v19.4 ve üzeri sürümlerden başlayarak gereklidir. Şu yeni Avamar sürümleri için en son düzeltmelerin yapılandırılması ve yüklenmesi ile ilgili talimatları içeren aşağıdaki KB makalesini kullanın:

KB Avamar Hyper-V VSS eklentisi: 19.4 ve sonrası için En Son Toplu HF'lerin Yapılandırılması ve Yüklenmesi 

Affected Products

Avamar, Avamar Plug-in for Hyper-V VSS
Article Properties
Article Number: 000181941
Article Type: Solution
Last Modified: 26 Feb 2026
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.