PowerStore: NAS server not reachable due to NTP unavailability

Summary: NAS server not reachable, caused by NTP server not being available from the PowerStore system

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Unable to reach a NAS server from the client, the error message "Windows cannot access \\X.X.X.X." When trying to access by using "dir \\X.X.X.X" in cmd, the error message is "Could not find the domain controller for this domain."
In the journal logs you see errors concerning time sync, for example:

WARNING: kerberos function 'krb5_sendto_kdc' fails. Returning time error: Clock skew too great

You can also verify that connectivity to the domain controller is failing from the PowerStore CLI:

[SVC:service@SVCTAGX-B user]$ svc_nas_cifssupport --server nas-server-x --args "-checkup "
nas-server-x
Error: unable getting a reply from '[xxxxxxxxxxxxxxxx]:5082'.
Error: timeout

nas-server-x :
------------------------------------Checks--------------------------------------

Component CIFS :

ACL       : Checking the number of ACLs per file system. ..................*Pass
Connection: Checking the load of CIFS TCP connections. .................... Pass
Credential: Checking the validity of credentials. ......................... Pass
DC        : Checking the connectivity and configuration of Domain Controlle*FAILURE
DFS       : Checking the DFS configuration files and DFS registry. ........ Pass
DNS       : Checking the DNS configuration and connectivity to DNS servers. Pass
EventLog  : Checking the configuration of Windows Event Logs. ............. FAILURE
FS_Type   : Checking the dirType of each file system (DIR3 format for UFS32 Pass
GPO       : Checking the GPO configuration. ............................... FAILURE
HomeDir   : Checking the configuration of home directory shares. .......... Pass
I18N      : Checking the I18N mode and the Unicode/UTF8 translation tables. Pass
Kerberos  : Checking password updates and AES for Kerberos. ...............

 

Cause

The NTP server cannot be reached by the system. The Kerberos authentication fails because of the time skew.
The same NTP server may have worked previously but if unreliable it could be that it has now become unreachable.

Confirm this with the "svc_ntp_ctl" command (you can also try to re-sync simultaneously by adding the --set flag)

[SVC:service@SVCTAGX-B user]$ svc_ntp_ctl --set
   INFO: Cluster is configured to use the following NTP servers: xx.xx.xx.xx
  ERROR: Node B could not reach any valid time server.
   INFO: Time sync service restarted successfully
  ERROR: Node A could not reach any valid time server.
   INFO: Time sync service restarted successfully

 

Resolution

Check NTP server availability and reachability, if necessary change to a different NTP server that is up and reachable (from PowerStore Manager > Settings > Networking > Infrastructure Services).
Then force a sync again, this time it should be successful, and after that you could reach the NAS server again.

[SVC:service@SVCTAGX-B user]$ svc_ntp_ctl --set
   INFO: Cluster is configured to use the following NTP servers: xx.xx.xx.x1, xx.xx.xx.x2
   INFO: Node B synced with server xx.xx.xx.x1 and has an offset of 0.000982 seconds
   INFO: Time sync service restarted successfully
   INFO: Node A synced with server xx.xx.xx.x2 and has an offset of 0.001301 seconds
   INFO: Time sync service restarted successfully

 

Affected Products

PowerStore, PowerStore 1000X, PowerStore 1000T, PowerStore 3000X, PowerStore 3000T, PowerStore 5000X, PowerStore 5000T, PowerStore 7000X, PowerStore 7000T, PowerStore 9000T

Products

PowerStore 9000X
Article Properties
Article Number: 000182993
Article Type: Solution
Last Modified: 20 Jan 2025
Version:  2
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