Nœuds de navigation ou icônes de menu manquants après la mise à niveau de l’interface utilisateur Admin

Summary: En l’absence d’éléments de menu ou de nœuds après la mise à niveau de l’interface utilisateur Admin, vérifiez les propriétés communes si l’URL est absente du fichier.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Les nœuds de navigation ou les éléments de menu absents de l’interface utilisateur Admin
Home
Discovery 
et Config comportent des nœuds de navigation manquants pour les alertes, les solution Packs, les groupes et les balises, la mise à jour du système et les paramètres. 


image.png
 

Cause

L’hôte front-end ne disposait pas de l’URL pour les modules sous opt\APG\Web-Applications

Resolution

Sur l’hôte front-end [winscp, il serait intéressant de suivre la procédure ci-dessous];
Accédez à \opt\APG\Web-Applications, vérifiez le nœud module/navigation manquant dans l’interface utilisateur

Exemple :
\Centralized-Management\centralized-management\conf\common.properties
l’URL ci-dessous n’est pas présente dans le fichier :

 apg.centralized-management.url=

Ajoutez l’URL: 
apg.centralized-management.url=/centralized-management/

Puis, enregistrez le fichier.

Les autres nœuds manquants de l’URL sont les suivants :
apg.alerting-frontend.url=

apg.compliance-frontend.url=
apg.device-discovery.url=

URL fournie comme suit :


apg.alerting-frontend.url=/alerting-frontend/
apg.compliance-frontend.url=/compliance-frontend/
apg.device-discovery.url=/device-discovery/

 
Redémarrez le service tomcat par défaut tomcat APG/bin/manage-module.(sh/cmd)

Affected Products

SRM, SRM
Article Properties
Article Number: 000187298
Article Type: Solution
Last Modified: 03 Nov 2021
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.