PowerEdge: SRM UI에서 어레이 쌍을 추가하는 동안 SRDF SRA 오류가 발생하여 어레이 관리 호스트에 연결하지 못함

Summary: SRA 명령 'discoverArrays'에 실패했습니다. 어레이 관리 호스트에 연결하지 못했습니다. 오류에 대한 자세한 내용은 EmcSrdfSra 로그를 확인하십시오.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

SRM UI에서 SRA(SRDF Replication Adapter)를 사용하여 어레이 페어를 추가하는 동안

"SRA command ‘discoverArrays’ failed. Failed to connect to the array management host. Please check EmcSrdfSra logs for more information on the error."


경고 

이 문제가 발생한 설정에 대한 추가 정보:
vCenter 버전: 6.7
SRM 버전: 8.1
SRA 버전: 9.2.0
SE 버전: SRM
SYMAPI Server에 설치된 9.2.1 클라이언트: SE 9.2.1의 내장형 매니지드 어레이

Cause

symapi 다음 오류로 인해 SRM 클라이언트에서 SYMAPI 서버로 세션을 초기화할 수 없습니다.

"The trusted host file disallowed a client server connection"



즉, SYMAPI 서버의 "nethost" 파일이 잘못 구성되었거나 전혀 구성되지 않았습니다. 신뢰할 수 있는 호스트 파일은 "nethost" 파일.

EmcSrdfSra.log에서 오류 발견 :

[07/26 09:50:59.104  8768   155 SymapiSession::Init             ] [ERROR]: Failed to perform SymInit(). 
[ERROR]: [SYMAPI_C_HOST_FILE_REJECTION : The trusted host file disallowed a client server connection]
.
[07/26 09:50:59.104  8768    33 SymapiSession::SymapiSession    ] [ERROR]: Failed to initialize Symapi session


SYMAPI 서버의 storsrvd.log에서 오류가 발견되었습니다.

<Error> [7564             SESS 0125] Jul-25 14:09:46.372 : ANR0018E Rejecting session 125 for dell_user@dellemc123.abc.def.com (::ffff:111.222.333.444): The trusted host file disallowed a client server connection


SRM 클라이언트에서 SYMAPI 서버로의 세션이 사용자로 거부되었습니다. dell_user 또는 호스트 FQDN dellemc123.abc.def.com SYMAPI 서버에 대한 액세스 권한이 없습니다. 다음을 사용하여 액세스 권한을 제공해야 합니다. nethost 파일을 SYMAPI 서버에 저장합니다. 이 오류는 SYMAPI 서버가 가상 어플라이언스 또는 Embedded Management일 때 주로 발생합니다.

Resolution

로그를 검토하고 이 문제를 확인한 후 아래 해결 방법을 진행합니다. 
추가/구성 nethost 아래 형식의 호스트 FQDN/IP 및 사용자를 갖는 SYMAPI 서버의 파일:

<Host FDQN> <user>
<IP> <user>


예:

dellemc123.abc.def.com dell_user
111.222.333.444 dell_user

Affected Products

SRDF Adapter for VMware Site Recovery Manager, VMware vCenter Site Recovery Manager
Article Properties
Article Number: 000190090
Article Type: Solution
Last Modified: 22 Apr 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.