Problém SRM s přístupem k uživatelskému rozhraní systému FE po aktualizaci certifikátu
Summary: Po dokončení části "Konfigurace protokolu HTTPS s certifikáty podepsanými certifikační autoritou" v příručce "Průvodce zabezpečením a konfigurací M&R" není uživatelské rozhraní frontendu (FE) přístupné. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Prohlížeč může při přístupu k FE zobrazit následující zprávy:
Při prohlížení protokolů catalina na serveru FE se mohou zobrazit následující chybové zprávy:
"Vypršel časový limit připojení"
"Tento web není dostupný"
"Tento web není dostupný"
Při prohlížení protokolů catalina na serveru FE se mohou zobrazit následující chybové zprávy:
SEVERE: Nepodařilo se inicializovat koncový bod přidružený k ProtocolHandler ["http-nio-58443"]
java.security.UnrecoverableKeyException: Nelze obnovit klíč
Nebo
TĚŽKÉ: Nepovedlo se inicializovat konektor [Connector[HTTP/1.1-58443]]
org.apache.catalina.LifecycleException: Nepodařilo se inicializovat komponentu [Connector[HTTP/1.1-58443]]
Příčina: org.apache.catalina.LifecycleException: Inicializace obslužné rutiny protokolu se nezdařila
. Příčina: java.security.UnrecoverableKeyException: Nelze obnovit klíč
java.security.UnrecoverableKeyException: Nelze obnovit klíč
Nebo
TĚŽKÉ: Nepovedlo se inicializovat konektor [Connector[HTTP/1.1-58443]]
org.apache.catalina.LifecycleException: Nepodařilo se inicializovat komponentu [Connector[HTTP/1.1-58443]]
Příčina: org.apache.catalina.LifecycleException: Inicializace obslužné rutiny protokolu se nezdařila
. Příčina: java.security.UnrecoverableKeyException: Nelze obnovit klíč
Cause
Při procházení kroků "Konfigurace protokolu HTTPS s certifikáty podepsanými certifikační autoritou" došlo k problému, kdy se heslo klíče certifikátu lišilo od hesla úložiště klíčů.
Postup nápravy tohoto rozdílu není uveden v příručce konfigurace zabezpečení M&R.
Rozdíl musí být jasně uveden v souboru server.xml , jinak není uživatelské rozhraní KP přístupné.
Resolution
Na serveru FE opravte následující:
- Je při importu úložiště klíčů vytvořen alias pro klíč "apg-aliasname.pfx"?
Vzhledem k tomu, že umístění souboru nemusí být stejné jako na obrázku, proveďte na serveru FE následující příkaz:
find / -iname apg-a*
Vyhledejte "apg-aliasname.pfx" (přípona souboru může být také .PEM nebo . CRT).
find / -iname apg-a*
Vyhledejte "apg-aliasname.pfx" (přípona souboru může být také .PEM nebo . CRT).
- Pro klíč "apg-aliasname.pfx" se nastaví libovolné heslo.
Pokud je nastaven alias klíče a heslo, uveďte v souboru server.xml tento alias klíče, heslo klíče a také heslo úložiště klíčů.
Příklad: Do server.xml přidejte níže uvedené atributy.
keystorePass="sem vložte heslo úložiště klíčů"
keyPass="sem vložte heslo klíče"
keyAlias="sem vložte alias soukromého klíče"/>
Příklad: Do server.xml přidejte níže uvedené atributy.
keystorePass="sem vložte heslo úložiště klíčů"
keyPass="sem vložte heslo klíče"
keyAlias="sem vložte alias soukromého klíče"/>
- Aktualizujte a restartujte všechny moduly nebo služby.
Pomocí nástroje PuTTY přejděte na hostitele nebo server FE, přejděte do složky/opt/APG/bin, spusťte příkaz ./manage-modules.sh service update all apoté spusťte příkaz ./manage-modules.sh service restart all.
- Pokuste se získat přístup k FE, nyní by měl být přístupný.
Products
SRMArticle Properties
Article Number: 000190501
Article Type: Solution
Last Modified: 07 Oct 2025
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.