Problema de SRM al acceder a la interfaz del usuario de FE después de actualizar el certificado
Summary: Después de revisar "Configuración de HTTPS con certificados firmados por una autoridad de certificación" en la guía "Guía de configuración y seguridad de M&R", no se puede acceder a la interfaz de usuario de front-end (FE). ...
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Symptoms
El navegador puede mostrar los siguientes mensajes cuando se accede a FE:
Es posible que encuentre los siguientes mensajes de error cuando se observan los registros de catalina en el servidor FE:
"Se agotó el tiempo de espera de la conexión"
"No se puede acceder a este sitio"
"No se puede acceder a este sitio"
Es posible que encuentre los siguientes mensajes de error cuando se observan los registros de catalina en el servidor FE:
SEVERE: No se pudo inicializar el terminal asociado con ProtocolHandler ["http-nio-58443"]
java.security.UnrecoverableKeyException: No se puede recuperar la clave
O
GRAVE: No se pudo inicializar el conector [Connector[HTTP/1.1-58443]]
org.apache.catalina.LifecycleException: Error al inicializar el componente [Connector[HTTP/1.1-58443]]
Causado por: org.apache.catalina.LifecycleException: Error en la inicialización del
controlador de protocolo debido a: java.security.UnrecoverableKeyException: No se puede recuperar la clave
java.security.UnrecoverableKeyException: No se puede recuperar la clave
O
GRAVE: No se pudo inicializar el conector [Connector[HTTP/1.1-58443]]
org.apache.catalina.LifecycleException: Error al inicializar el componente [Connector[HTTP/1.1-58443]]
Causado por: org.apache.catalina.LifecycleException: Error en la inicialización del
controlador de protocolo debido a: java.security.UnrecoverableKeyException: No se puede recuperar la clave
Cause
Se producía un problema con la contraseña de la clave de certificado que era diferente de la contraseña del almacén de claves al seguir los pasos de "Configuración de HTTPS con certificados firmados por una autoridad de certificación".
El paso para rectificar esta diferencia no se menciona en la Guía de configuración de seguridad de M&R.
La diferencia se debe indicar claramente en el archivo server.xml o no se puede acceder a la interfaz de usuario de FE.
Resolution
En el servidor de FE, corrija lo siguiente:
- Durante la importación del almacén de claves, ¿se crea algún alias para la clave "apg-aliasname.pfx"?
Dado que la ubicación del archivo puede no ser la misma que se muestra, realice lo siguiente en el servidor FE:
find / -iname apg-a*
Busque "apg-aliasname.pfx" (la extensión del archivo también podría ser .PEM o . CRT).
find / -iname apg-a*
Busque "apg-aliasname.pfx" (la extensión del archivo también podría ser .PEM o . CRT).
- Cualquier contraseña está configurada para la clave "apg-aliasname.pfx".
Si se configuran el alias de clave y la contraseña, mencione el alias de clave, la contraseña de clave y también la contraseña de almacenamiento de claves en el archivo server.xml.
Ejemplo: Agregue los siguientes atributos en server.xml.
keystorePass="insertar contraseña del almacén de claves aquí"
keyPass="insertar contraseña de clave aquí"
keyAlias="insertar alias de clave privada aquí"/>
Ejemplo: Agregue los siguientes atributos en server.xml.
keystorePass="insertar contraseña del almacén de claves aquí"
keyPass="insertar contraseña de clave aquí"
keyAlias="insertar alias de clave privada aquí"/>
- Actualice y reinicie todos los módulos o servicios.
PuTTY en el host o servidor de FE, vaya a/opt/APG/bin, ejecute ./manage-modules.sh service update all y, a continuación,ejecute ./manage-modules.sh service restart all.
- Intente acceder al FE; ahora debería poder acceder a él.
Products
SRMArticle Properties
Article Number: 000190501
Article Type: Solution
Last Modified: 07 Oct 2025
Version: 2
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