PowerProtect | SQL Always On -tietokannan (AAG) erillinen DDBMA-varmuuskopiointi epäonnistuu

Summary: Data Domain DD Boost for Microsoft Applications (DDBMA) -tietokannan erillinen varmuuskopiointi AAG (SQL Always On Availability Group) -tietokannasta epäonnistuu

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Varmuuskopiointi näyttää onnistuneen, mutta tallennettu toimenpide (master.dbo.emc_run_backup) ilmoittaa virheestä ja seuraavista tapahtumista:

Virhesanoma:

Successfully converted from group id to AG name.

149283:ddbmsqlsv: Start secondary backup job failed. host: <hostname>. error: Setting notification event failed on host: <hostname>.
85942:ddbmsqlsv: Stopping Federated backup - No jobs were started successfully. Unable to complete the federated backup.


 

Cause

SQL Server -agenttityö suoritetaan SQL Server Agent -palveluun liitetyn käyttäjän kontekstissa. Tällä käyttäjätilillä oli kaikki tarvittavat käyttöoikeudet (SQL Serverin paikallinen järjestelmänvalvoja, täydet WMI (Windows Management Instrumentation) -käyttöoikeudet Microsoft App Agent -oppaan mukaisesti). Varmuuskopiointi toimii myös silloin, kun se suoritetaan SQL Server Management Studio (SSMS) -laajennuksesta, joka on kirjautunut sisään tällä käyttäjällä (liittyy SQL Server Agent -palveluun).

Jos varmuuskopion käyttäjä ei ole paikallinen järjestelmänvalvoja, hänellä ei ole tarvittaviaWMI-oikeuksia. Tämä selittää, miksi varmuuskopiointi onnistuu käyttöliittymässä, joka käyttää kirjautuneen käyttäjän tiliä, mutta epäonnistuu SQL:ssä, joka käyttää SQL-palvelutiliä.

Resolution

Varmista, että käyttäjä kuuluu paikallisen järjestelmänvalvojan ryhmään, ja lisää tarvittaessa SQL-palvelutili. Tarkista Kirjaudu sisään erätyönä tai Kirjaudu sisään palveluna - oikeudet, jotka myönnetään yleensä paikallisesta järjestelmänvalvojan tilasta. Lisää manuaalisesti, jos sitä ei ole. Jos ongelmia ei ilmene, käynnistä SQL Service -palvelu tai palvelin uudelleen, jotta paikalliset järjestelmänvalvojan oikeudet ovat käytössä.

Affected Products

PowerProtect App Direct, PowerProtect Software
Article Properties
Article Number: 000192006
Article Type: Solution
Last Modified: 07 Oct 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.