NetWorker NVP-vProxy: バックアップが次のエラーで失敗します。 VDDK Error: 13: 「このファイルへのアクセス権がありません。」「SCSIターゲットIDの割り当てに失敗しました」

Summary: Hotadd転送モードを使用したDell EMC NetWorker vProxyベースのバックアップでは、VMDKファイルへのアクセス権に関するVDDK 13エラーで1つ以上のVMが失敗していると表示されます。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

vProxyセッション ログには、次のエラーで失敗したVMが1つ以上表示されます。

2021-10-12T22:11:52Z ERROR:  [@(#) Build number: 78] 654f8808-ce2a-4472-9f50-e037ab7038b3:vm-231097:VCENTER: Failed to open source VMDK '[DATASTORE_NAME] VM-NAME/VM_NAME_#.vmdk': VDDK Error: 13: You do not have access rights to this file.
2021-10-12T22:11:52Z ERROR:  [@(#) Build number: 78] 654f8808-ce2a-4472-9f50-e037ab7038b3:vm-231097:VCENTER: Failed to initialize Block Reader.
2021-10-12T22:11:52Z ERROR:  [@(#) Build number: 78] 654f8808-ce2a-4472-9f50-e037ab7038b3:vm-231097:VCENTER: Failed to backup virtual disk "Hard disk 2".

vProxy VDDKのデバッグ ログを有効にすると、vbackupd-vddk.logに次のエラーが表示されます。

2021-10-12T18:11:52.409-04:00 error -[02778] [Originator@6876 sub=transport] Cannot use mode hotadd to access [DATASTORE_NAME] VM-NAME/VM_NAME_#.vmdk: Cannot mount using this method. (Mounting 421dd75d-c2a2-ff69-69d3-5b8f7cde98ca using transport hotadd failed : Failed to allocate SCSI target ID..)

 

Cause

原因は不明です。  vProxyは、デフォルトで4つのSCSIコントローラーを使用してOVAファイルから導入されます。  vProxyの導入時にSCSIコントローラーの数を変更するために使用できる構成オプションはありません。

ただし、導入された1つ以上のvProxyのハードウェア設定を確認すると、SCSIコントローラーが1つしか表示されません。  VDDKエラーが発生しているのは、vProxyに予想されるデフォルトの4つのSCSIコントローラーがなく、バックアップ中に追加のクライアント ディスクをマウントする領域が不足しているためです。

Resolution

この問題を解決するには、次の手順を実行します。
1.  NMC(NetWorker管理コンソール)で実行されているvProxyバックアップがないことを確認します。
2.  VMwareでvProxy VMをシャットダウンします。
3.  [Edit Settings]に移動し、欠落しているSCSIコントローラーを影響を受けるvProxyに追加すると、合計4.
になります。4.  vProxyを再起動します。  新しいコントローラーを検出して自動構成します。

完了すると、vProxyハードウェア設定は次のようになります。
SCSI_cfg.JPG

Additional Information

NVP-vProxy:デバッグ ログを有効にする方法

手記:「アクセス権がありません」というエラーは他の理由で表示されることがあります。この場合、メッセージは「SCSIターゲットIDの割り当てに失敗しました」に関連していました。「アクセス権がありません」エラーに関するその他のドキュメントについては、次を参照してください。

Affected Products

NetWorker

Products

NetWorker Family, NetWorker Series
Article Properties
Article Number: 000192687
Article Type: Solution
Last Modified: 06 Apr 2022
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.