VPLEX : Le firmware d’un directeur peut se bloquer en raison d’un bogue lié à la couche du cache

Summary: Cet article traite d’un problème lié à un directeur VPLEX qui peut rencontrer une erreur provoquant une défaillance de son firmware.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Matériel Dell concerné :
VPLEX-Series
VPLEX-VS2
VPLEX-VS6
VPLEX-Local
VPLEX-Metro-FC et IP

Logiciel Dell concerné :
GeoSynchrony 6.0.x

Impact :
Le firmware du directeur redémarre, mais l’impact doit normalement être nul sur les hôtes configurés pour HA.  Les hôtes n’ont plus accès au directeur lorsque le firmware se bloque, mais normalement l’accès doit être rétabli après le redémarrage automatique du firmware.

Problème :
Un directeur VPLEX peut être confronté à une défaillance du firmware qui entraîne la consignation du message suivant :

Motif de la défaillance : /export/local1/jenkins/clone_D50.10/nsfw/snac/cch/cache.c:invalidatePageWithHashImpl/1321: NULL dv on inval page 0x3e3209 flags 0x4 table 15

Cause

Une lecture de plusieurs pages est en suspens au niveau d’un directeur, et nous attendons l’accès à l’une de ces pages (pas la dernière) dans le cache pour pouvoir commencer. La liaison est interrompue, puis rétablie, et nous apprenons que l’autre cluster a poursuivi les E/S sur le volume en question pendant que la liaison était interrompue. Dans le cadre du nettoyage des E/S en suspens sur le cluster de lecture, nous faisons une erreur d’indexation et accédons au mauvais champ d’une baie, ce qui entraîne l’échec d’une vérification de cohérence.

Resolution

Résolution :
Ce problème a été corrigé dans GeoSynchrony 6.1.x et versions ultérieures.

Il n’existe aucune solution de contournement. Pour éviter de rencontrer à nouveau ce problème, la seule solution consiste à mettre le système VPLEX à niveau vers la dernière version du code.

Affected Products

VPLEX Series, VPLEX VS2, VPLEX VS6
Article Properties
Article Number: 000196501
Article Type: Solution
Last Modified: 11 Jun 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.