NetWorker: Error Creating Cloud Tier Device "Data Movement Policy exists for the MTree"

Summary: This article provides instructions on how to address the error "Data Movement Policy exists for the MTree" when creating a new cloud tier device.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The following error message appears in the NMC device creation wizard when the user creates a new cloud tier device:
Unable to create the data movement policy for mtree <mtreename> and cloud unit <cloudunitname> *** Data Movement Policy exists for the mtree.
Screenshot of error message Policy exists for MTree

Cause

The Cloud Tier Device was deleted, but the previous data-movement policy is still associated with the MTree.

According to the Dell NetWorker and Data Domain Boost Integration Guide, each MTree can have only one data movement policy:
 
Screenshot from guide stating Each MTree can have only one data movement policy

Resolution

Manually delete the data-movement policy of the MTree:

data-movement policy show
sysadmin@dell-lab-bkp01# data-movement policy show
MTree                     Target(Tier/Unit Name) Policy      Value
--------------------      ---------------------- ----------- -------
/data/col1/dell-lab-bkp01 Cloud/dell-lab-bkp01   app-managed enabled
--------------------      ---------------------- ----------- -------
sysadmin@dell-lab-bkp01#
data-movement policy reset app-managed mtrees <mtree name>
sysadmin@dell-lab-bkp01# data-movement policy reset app-managed mtrees /data/col1/dell-lab-bkp01
The data-movement "app-managed" policy for Mtree(s) "/data/col1/dell-lab-bkp01" is reset to "none"
sysadmin@dell-lab-bkp01#
data-movement policy show
sysadmin@dell-lab-bkp01# data-movement policy show
No Mtrees have data-movement policy set.
sysadmin@dell-lab-bkp01#

Affected Products

NetWorker Family, NetWorker, NetWorker Series, NetWorker Management Console
Article Properties
Article Number: 000197231
Article Type: Solution
Last Modified: 13 Feb 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.