Latitude 5430 RuggedおよびLatitude 7330 Rugged Extremeでシリアル ポートまたはボー レートを割り当てることができない u-blox GPS

Summary: この記事では、Dell Latitude 5430 RuggedまたはLatitude 7330 Rugged Extremeでのシリアル ポート割り当ての問題またはボー レートについて説明します。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

GPSアプリケーションが特定のポート#を必要とせず、Windowsのデフォルトのボーレートである38400で動作する場合。必要になる可能性が高い唯一の構成変更は、デバイス マネージャーの[センサー]で[電源管理]がオンになっていないことを確認することです(図1を参照)
ただし、アプリケーションで特定のポートやボー レートが必要な場合は、そのままでは機能しません
デバイス マネージャーの[センサー]で、[電源管理]がチェックされていないことを確認します
電源管理
図 1.電源管理

Cause

これは設計どおりの正常な動作です。アプリケーションがデフォルト設定で動作しない場合は、以下の手順に従ってください。

Resolution

  1. デバイス マネージャーの[センサー]で、[電源管理]がチェックされていないことを確認します。
  2. COMPort_Assignmentユーティリティーを使用して、COMポート#を必要な値に設定します。
    • https://ftdichip.com/utilities/External_Link_Iconに移動 
    • [COMPort_Assignmentユーティリティー]セクションまで下にスクロールし、.zipファイルをダウンロードして開きます
    • ReAssignCOMPortNumb.exeファイルを実行してユーティリティーをインストールします
  3. アプリケーションを起動して、ComPortを割り当てます(図2を参照)。
    COMPort割り当てユーティリティ
    図2COMPort Assignment Utility
    このユーティリティは、GPSポートを自動的に検出します。アプリに必要なCOMポートを選択し、[Assign Com Port]を押してから、[Exit]を押します
    デバイス マネージャーのCOMポートが変更されていることに注意してください。すべてのアプリケーションが新しいCOMポートを認識するには、再起動が必要です。
  4. U-Centerを使用して、次の手順でボーレートを変更します
    • U-Centerを開き、ツールバーで[Receiver/Connection]をクリックして、デバイス マネージャーにリストされているポートを選択します。
    • [Receiver/Baud Rate]をクリックして、[38400]に設定します。
    • ツールバーで、表示/構成ビューをクリックし、左ペインで[PRT(ポート)]を見つけてクリックします。
      • 右ペインのボー レートを9600に変更し、[Send]をクリックします。(図3を参照)
        右ペインのボー レート
        図 3.右ペインのボー レート
      • 次に、[View]>>[Message View]をクリックし、左側のペインで[UBX]>>[CFG Config]>>[CFG Configuration]を展開します
        設定の確認
        図4。構成の確認
    • 構成が一致することを確認し(図4を参照)、[Send]ボタンをクリックします。
    • Uセンターに戻り、ボーレート9600と選択したCOMポートでGPSをテストします。
 

Affected Products

Latitude 7330 Rugged Extreme, Latitude 5430 Rugged
Article Properties
Article Number: 000201221
Article Type: Solution
Last Modified: 28 May 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.