PowerStore: PowerStore is Not Discoverable by VSI After Upgrade to PowerStoreOS Version 3.2.0.0
Summary: PowerStore is not discoverable by VSI after upgrade to PowerStoreOS version 3.2.0.0.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
PowerStore is not discoverable by VSI after upgrading PowerStore to version 3.2.0.0.
Before the upgrade, everything works as expected, but after upgrading to PowerStoreOS v3.2.0.0, VSI is no longer able to connect to the PowerStore.
If removed, it does not re-register. The following error message is displayed on vSphere:
Before the upgrade, everything works as expected, but after upgrading to PowerStoreOS v3.2.0.0, VSI is no longer able to connect to the PowerStore.
If removed, it does not re-register. The following error message is displayed on vSphere:
400 Failed to discover PowerStore systems.
Figure 1: Error Message: Failed to Discover PowerStore Systems
The affected VSI plug-in version is 10.0.0.
Cause
Changes in the REST API on PowerStoreOS version 3.2 cause VSI 10.0.0 to no longer work with PowerStore v3.2
Resolution
VSI versions 10.1.0 and 10.2.0 are available for download at the Product Page of VSI for VMware vSphere Web Client on Dell Support. Install the new VSI release.
Affected Products
PowerStoreArticle Properties
Article Number: 000205413
Article Type: Solution
Last Modified: 14 Jun 2023
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.