PowerStore: Drive Addition May Cause Node Reboot on 500T

Summary: During drive addition to expand appliance capacity of a PowerStore 500T, the BMC may experience a Watchdog reset which then may lead to a node rebooting.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Adding drives to expand appliance capacity can cause a single node to reboot and return to service. Capacity expansion continues during this process.

Impact: High Availability (HA) is degraded while the node reboots.


Factors Affecting the Issue

  1. Drive Slot Impact

    • Issue is mainly seen when adding a drive to slot 12 (may lead to Node A reboot) or slot 13 (may lead to Node B reboot).
  2. Timing of Drive Additions

    • Issue can also occur when adding drives in quick succession.

Cause

The Baseboard Management Controller (BMC) generates a hardware watchdog event as the drive is installed, which triggers the node reboot.

Resolution

This issue has been resolved in PowerStoreOS code streams LTS-v4.1.0.4 and v4.3.x and higher
Action: Upgrade to PowerStoreOS to prevent node reboots during capacity expansion.

 

Workaround: 

To avoid a service disruption for this issue, follow the process detailed in KB#000296002 PowerStore: Procedure for adding drives on 500T

 

Note: If adding drives to a PowerStore cluster at code levels below PowerStoreOS LTS-v4.1.x, also review the following KBs relating to the need to update DriveDB.json:

Contact Dell Technical Support for questions or assistance.

Reference this KB Article in the Service Request for expedited handling.

Affected Products

PowerStore 500T
Article Properties
Article Number: 000220636
Article Type: Solution
Last Modified: 22 Dec 2025
Version:  20
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.