NetWorker: REST API log folder is missing

Summary: This KB provides instructions on how to reconfigure REST API logging if the restapi logs directory does not exist.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The NetWorker server's REST Application Programming Interface (API) logs directory is missing:

  • Linux: /nsr/logs/restapi
  • Windows: C:\Program Files\EMC NetWorker\nsr\logs\restapi

Restarting services does not re-create the REST API log directory.

Cause

The REST API logs folder was renamed or deleted, either accidentally by a user or as part of a troubleshooting attempt.

Resolution

On Windows servers, re-creating the C:\Program Files\EMC NetWorker\nsr\logs\restapi directory should resolve the issue. Once the folder is created, the restapi.log should appear; however, a NetWorker service restart may be required. This path assumes the default NetWorker installation path is used. If another drive or installation path is used, the 'restapi' folder should be created under the ..\nsr\logs location. 

On Linux servers, you must perform the following:

NOTE: See Additional Info field if the NetWorker server is deployed on a pacemaker (pcs) cluster.

1. Re-create the REST API logs folder:

sudo mkdir /nsr/logs/restapi

2. Set permissions on the folder:
sudo chmod 755 /nsr/logs/restapi

3. Change ownership of the folder to nsrtomcat:
sudo chown -R nsrtomcat:nsrtomcat /nsr/logs/restapi
 
4. Restart NetWorker:
systemctl restart networker

5. The REST API log should be re-created and show a nwrestapi service startup.

Example of nwrestapi service startup

Additional Information

Affected Products

NetWorker

Products

NetWorker Family, NetWorker Series
Article Properties
Article Number: 000221945
Article Type: Solution
Last Modified: 30 Apr 2025
Version:  3
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