NetWorker:NWUIのブラウズ可能なリカバリーでChangeSecuritySettingsまたはViewSecuritySettingsの権限が要求される
Summary: NWUIでブラウズ可能なリカバリーを実行するときに、NWUIにログインしたユーザーがChangeSecuritySettingsまたはViewSecuritySettings権限を持っていない場合、リカバリー対象のファイルを手動で参照することはできません。
Symptoms
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「operators」グループに属するユーザーを使用して、NWUIでブラウズ可能なリストアを実行します。

図1:NWUI - リカバリーとセーブセット ビュー
図2:NWUI - ファイル レベル リカバリーの選択 -
ここで[参照]をクリックして回復する必要のあるファイルを見つけると、次のエラーが表示されます。
![[BROWSE]オプションが表示されている[NWUIリカバリー]ウィザード](https://supportkb.dell.com/img/ka06P000000LnbZQAS/ka06P000000LnbZQAS_ja_3.jpeg)
図3:リカバリ ウィザード - [Browse]ボタン ビュー![[BROWSE]オプションを選択した後にリカバリー ウィザードで障害が発生した](https://supportkb.dell.com/img/ka06P000000LnbZQAS/ka06P000000LnbZQAS_ja_4.jpeg)
図4:Recovery Wizard - 図3の[Browse]ボタンをクリックすると失敗するエラー メッセージは、次のとおりです。
Could not get directory contents. Permission denied. User <user> has no ChangeSecuritySettings or ViewSecuritySettings privilege.
ユーザーは、ブラウズ可能なリカバリーを実行するためにこのような権限を必要としません。たとえば、NMCでは必要ありません。
当面の間、NWUIでこの操作を実行する必要がある場合は、 ViewSecuritySettings 権限をユーザーに付与する必要があります。 -
この問題が発生しても、リカバリの実行は避けられません。リカバリするファイルを選択できなくなるだけです。リカバリーするパスを手動で配置することもできます。

図5:リカバリ ウィザード - リカバリ元のパスを手動で入力します。 -
[Next]をクリックすると、リカバリーが正常に実行されます。

図6:リカバリー ウィザード - [基本構成]オプション。ここでも、[参照]ボタンを使用してリカバリー先のパスを選択できます。 -
上記の画面でもう一度、[参照]をクリックすると失敗しますが、ファイルを指示するパスを手動で入力することは停止しません。

図7:リカバリ ウィザード - リカバリ元のパスを手動で入力すると、リカバリが正常に完了します。[Finish]をクリックすると、[recover jobs]タブに完了したことが表示されます。

図8:NWUI - リカバリーが正常に完了したことを示すリカバリー ジョブ ビュー
Cause
この問題は、次のコードの欠陥が原因で発生していました。NETWORKER-91941
Resolution
現在の時点では、修正されたバージョンはありません。