NetWorker: Die durchsuchbare NWUI-Recovery fragt nach der Berechtigung "ChangeSecuritySettings" oder "ViewSecuritySettings".
Summary: Wenn Sie eine durchsuchbare Recovery in der NWUI durchführen, können Sie die wiederherzustellenden Dateien nicht manuell durchsuchen, wenn der Nutzer, den Sie bei der NWUI angemeldet haben, nicht über die Berechtigung ChangeSecuritySettings oder ViewSecuritySettings verfügt. ...
Symptoms
-
Durchführen einer durchsuchbaren Wiederherstellung in der NWUI mit einem Nutzer, der zur Gruppe "operators" gehört:

Abbildung 1: NWUI – Ansicht "Recover" und "Savesets"
Abbildung 2: NWUI – Auswählen der Recovery auf Dateiebene -
Wenn Sie hier auf "Durchsuchen" klicken, um die Dateien zu finden, die Sie wiederherstellen müssen, wird der folgende Fehler angezeigt:

Abbildung 3: Recovery-Assistent – Ansicht der Schaltfläche "Browse"
Abbildung 4: Recovery-Assistent – Fehler nach dem Klicken auf die Schaltfläche "Browse" in Abbildung 3Die Fehlermeldung lautet:
Could not get directory contents. Permission denied. User <user> has no ChangeSecuritySettings or ViewSecuritySettings privilege.
Der Nutzer sollte eine solche Berechtigung nicht benötigen, um eine durchsuchbare Recovery durchzuführen. NMC zum Beispiel benötigt sie nicht.
Wenn Sie diesen Vorgang in der NWUI ausführen müssen, müssen Sie dem Benutzer vorerst die Berechtigung ViewSecuritySettings gewähren. -
Dieses Problem hindert Sie nicht daran, die Recovery auszuführen. Sie müssen nur die wiederherzustellenden Dateien auswählen. Wir hätten den Pfad für die Wiederherstellung einfach manuell eingeben können:

Abbildung 5: Wiederherstellungsassistent: manuelle Eingabe eines Pfads für die Wiederherstellung. -
Klicken Sie auf Next und führen Sie die Recovery erfolgreich durch.

Abbildung 6: Recovery-Assistent – Option "Basic Configuration", bei der Sie mithilfe der Schaltfläche "Browse" einen Pfad für die Wiederherstellung auswählen können. -
Auf dem obigen Bildschirm schlägt es wieder fehl, wenn wir auf "DURCHSUCHEN" klicken, aber das hindert uns nicht daran, den Pfad, in den wir unsere Dateien leiten möchten, manuell einzugeben.

Abbildung 7: Recovery-Assistent: Erfolgreiche Recovery bei manueller Eingabe der Pfade, von/zu denen die Wiederherstellung erfolgen soll.Nachdem Sie auf "Finish" geklickt haben, können wir überprüfen, ob die Wiederherstellungsjobs abgeschlossen sind:

Abbildung 8: NWUI – Ansicht "Recover Jobs" mit der manuellen Eingabe der Pfade zur Wiederherstellung/zu deren manueller Eingabe war erfolgreich.
Cause
Dieses Problem wurde durch einen Codefehler verursacht: NETWORKER-91941
Resolution
Bis heute gibt es keine Version mit der Korrektur.