Solutions Enabler: storapid daemon keeps exiting

Summary: As a non-root user, the customer tries to start the storapid; however, it continues to exit.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

storapid log:
 
[12445             Listener] May-08 16:30:11.914 : storapid Starting, Version: V10.1-2752 (0.1) [RT]
[12445             Listener] May-08 16:30:11.914 : SE Package Version: 10.1.0.1 (Patch, Build 2752, 2024-02-17 02:44:21)
[12445             Listener] May-08 16:30:11.927 : [acquire_gk_lock()] Gatekeeper lock mode is 'FREE'
<Fatal> [12445             Listener] May-08 16:30:11.928 : [daemon_init()] storapid Daemon : not running under a privileged account - shutting down
[12445             Listener] May-08 16:30:11.928 : storapid Daemon : shutting down due to previous initialization failure
<Error> [12445             Listener] May-08 16:30:11.928 : storapid initialization routine failed with 2 - exiting
[12445             Listener] May-08 16:30:11.928 : storapid Exiting

Cause

  • The storapid daemon is working as designed,
  • The storapid daemon must be started will full root privileges. 

Resolution

With full root user privileges, start storapid (or a symcfg discover should do the same)
 
# stordaemon start storapid
Check with the below command (or equiv) command, and you would see the process and root ownership that started it
ps -auxw

Additional Information

NOTE:

It is rare that the storapid daemon must be manually shutdown or restarted.

The storapid daemon is essential for the Solutions Enabler to work.

Affected Products

Solutions Enabler Series
Article Properties
Article Number: 000225967
Article Type: Solution
Last Modified: 16 Sept 2024
Version:  3
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