PowerFlex: El proceso de SDS entra en estado de alarma continuamente en la función MosAsyncIO_ReqAccounting
Summary: Durante una conversión manual o de SVM PFMP y una actualización manual del componente PowerFlex, el SDS puede fallar continuamente si el archivo de rep_tgt.txt no se crea correctamente. ...
Symptoms
El proceso de SDS entra en estado de alarma continuamente con el siguiente seguimiento de la pila:
2024/05/27 08:11:10.051615 Panic in file /data/build/workspace/ScaleIO-Common-Job/src/mos/usr/linux/mos_async_io.c, line 1107, function mosAsyncIO_ReqAccounting, PID 21157.Panic Expression pOsReq->accounting.totalLenSubmittedBytes == pReq->bytesIO /opt/emc/scaleio/sds/bin/sds-4.5.2000.135(mosDbg_PanicPrepare+0xf4) [0x936f74] /opt/emc/scaleio/sds/bin/sds-4.5.2000.135(mosAsyncIO_ReqAccounting+0x26b) [0x95398b] /opt/emc/scaleio/sds/bin/sds-4.5.2000.135() [0x953b4e] /opt/emc/scaleio/sds/bin/sds-4.5.2000.135(mosAsyncIO_Reaper+0xab8) [0x959dc8] /opt/emc/scaleio/sds/bin/sds-4.5.2000.135(mosOsThrd_StartFunc+0x15a) [0x94056a] /lib64/libpthread.so.0(+0xa6ea) [0x7f0629c166ea] [(nil)]
Antes de la alarma de SDS, los registros de seguimiento de SDS indican un problema durante la lectura de /opt/emc/scaleio/sds/cfg/rep_tgt.txt:
2024/05/27 08:10:36.501247 LOW:7fa41442ddb0:mos_ReadParamFromSysPath:01442: ERROR: Failed to stat sys file /sys/dev/block/0:55/partition, errno: 2 2024/05/27 08:10:36.501253 MED:7fa41442ddb0:mos_GetDevMaxIoSizeBytesFromFD:01565: Could not read parameter for file 28 (path /sys/dev/block/0:55/partition), assuming 256. 2024/05/27 08:10:36.501260 MED:7fa41442ddb0:mosAsyncIO_OpenFileEx:00463: Opened file /opt/emc/scaleio/sds/cfg/rep_tgt.txt (fd 28), maxInflight 8, maxIoSize 256, ptr 0x7fa42c14a450
Producto afectado: PowerFlex 3.x y 4.x
Cause
SDS tiene un problema al intentar acceder al archivo de rep_tgt.txt.
Resolution
Si la solicitud en rep_tgt.txt No existe:
-
-
-
Recupere los ID necesarios desde el MDM principal:
- Obtenga MDM_ID:
scli --query_all | grep ID | head -n1 - Obtenga SDS_ID: (Consulte la SDS en cuestión)
scli --query_all_sds
- Obtenga MDM_ID:
-
Cree el archivo
rep_tgt.txtcon los ID recuperados. Reemplace MDM_ID y SDS_ID de la salida anteriorecho -n "mdmId=<MDM_ID>,tgtId=<SDS_ID>" > /opt/emc/scaleio/sds/cfg/rep_tgt.txt truncate -s 4096 /opt/emc/scaleio/sds/cfg/rep_tgt.txtEjemplo:
echo -n "mdmId=e7db67b7c2e2190f,tgtId=2514c01a00000003" > /opt/emc/scaleio/sds/cfg/rep_tgt.txt truncate-s 4096 /opt/emc/scaleio/sds/cfg/rep_tgt.txt -
Inicie el demonio de SDS:
/opt/emc/scaleio/sds/bin/create_service.sh
-
-
Si la solicitud en rep_tgt.txt Existe:
-
-
Verifique que el ID de MDM y el ID de SDS correctos estén dentro del archivo.
cat /opt/emc/scaleio/sds/cfg/rep_tgt.txt -
Compruebe el tamaño del archivo (debe ser de 4096 bytes):
ls -l /opt/emc/scaleio/sds/cfg/rep_tgt.txt -
Si el archivo tiene menos de 4096 bytes:
- Respalde el archivo existente:
cp /opt/emc/scaleio/sds/cfg/rep_tgt.txt /opt/emc/scaleio/sds/cfg/rep_tgt.txt.bak - Cambie el tamaño del archivo:
truncate -s 4096 /opt/emc/scaleio/sds/cfg/rep_tgt.txt - Verifique el nuevo tamaño de archivo
- Respalde el archivo existente:
- Inicie el demonio de SDS:
/opt/emc/scaleio/sds/bin/create_service.sh
-
Si el estado de alarma del SDS sigue ocurriendo después de seguir la solución alternativa, póngase en contacto con el soporte de Dell para obtener más ayuda.