PowerFlex: Processo de SDS entra em pane contínua na função MosAsyncIO_ReqAccounting
Summary: Durante uma conversão SVM manual ou PFMP e upgrade manual do componente PowerFlex, o SDS pode falhar continuamente se o arquivo rep_tgt.txt não for criado corretamente.
Symptoms
O processo de SDS entra em pane contínua com o seguinte rastreamento de pilha:
2024/05/27 08:11:10.051615 Panic in file /data/build/workspace/ScaleIO-Common-Job/src/mos/usr/linux/mos_async_io.c, line 1107, function mosAsyncIO_ReqAccounting, PID 21157.Panic Expression pOsReq->accounting.totalLenSubmittedBytes == pReq->bytesIO /opt/emc/scaleio/sds/bin/sds-4.5.2000.135(mosDbg_PanicPrepare+0xf4) [0x936f74] /opt/emc/scaleio/sds/bin/sds-4.5.2000.135(mosAsyncIO_ReqAccounting+0x26b) [0x95398b] /opt/emc/scaleio/sds/bin/sds-4.5.2000.135() [0x953b4e] /opt/emc/scaleio/sds/bin/sds-4.5.2000.135(mosAsyncIO_Reaper+0xab8) [0x959dc8] /opt/emc/scaleio/sds/bin/sds-4.5.2000.135(mosOsThrd_StartFunc+0x15a) [0x94056a] /lib64/libpthread.so.0(+0xa6ea) [0x7f0629c166ea] [(nil)]
Antes da pane do SDS, os registros de rastreamento do SDS indicam um problema durante a leitura de /opt/emc/scaleio/sds/cfg/rep_tgt.txt:
2024/05/27 08:10:36.501247 LOW:7fa41442ddb0:mos_ReadParamFromSysPath:01442: ERROR: Failed to stat sys file /sys/dev/block/0:55/partition, errno: 2 2024/05/27 08:10:36.501253 MED:7fa41442ddb0:mos_GetDevMaxIoSizeBytesFromFD:01565: Could not read parameter for file 28 (path /sys/dev/block/0:55/partition), assuming 256. 2024/05/27 08:10:36.501260 MED:7fa41442ddb0:mosAsyncIO_OpenFileEx:00463: Opened file /opt/emc/scaleio/sds/cfg/rep_tgt.txt (fd 28), maxInflight 8, maxIoSize 256, ptr 0x7fa42c14a450
Produto afetado: PowerFlex 3.x e 4.x
Cause
O SDS tem um problema ao tentar acessar o arquivo rep_tgt.txt.
Resolution
Se a solicitação do rep_tgt.txt Não existe:
-
-
-
Recupere os IDs necessários do MDM principal:
- Obtenha MDM_ID:
scli --query_all | grep ID | head -n1 - Obtenha SDS_ID: (Veja o SDS em questão)
scli --query_all_sds
- Obtenha MDM_ID:
-
Crie o
rep_tgt.txtcom os IDs recuperados. Substitua MDM_ID e SDS_ID da saída acimaecho -n "mdmId=<MDM_ID>,tgtId=<SDS_ID>" > /opt/emc/scaleio/sds/cfg/rep_tgt.txt truncate -s 4096 /opt/emc/scaleio/sds/cfg/rep_tgt.txtExemplo:
echo -n "mdmId=e7db67b7c2e2190f,tgtId=2514c01a00000003" > /opt/emc/scaleio/sds/cfg/rep_tgt.txt truncate-s 4096 /opt/emc/scaleio/sds/cfg/rep_tgt.txt -
Inicie o daemon do SDS:
/opt/emc/scaleio/sds/bin/create_service.sh
-
-
Se a solicitação do rep_tgt.txt Existe:
-
-
Verifique se o ID do MDM e o ID do SDS corretos estão dentro do arquivo.
cat /opt/emc/scaleio/sds/cfg/rep_tgt.txt -
Verifique o tamanho do arquivo (deve ser de 4.096 bytes):
ls -l /opt/emc/scaleio/sds/cfg/rep_tgt.txt -
Se o arquivo for menor que 4.096 bytes:
- Faça backup do arquivo existente:
cp /opt/emc/scaleio/sds/cfg/rep_tgt.txt /opt/emc/scaleio/sds/cfg/rep_tgt.txt.bak - Redimensione o arquivo:
truncate -s 4096 /opt/emc/scaleio/sds/cfg/rep_tgt.txt - Verificar o novo tamanho do arquivo
- Faça backup do arquivo existente:
- Inicie o daemon do SDS:
/opt/emc/scaleio/sds/bin/create_service.sh
-
Se a pane do SDS continuar ocorrendo depois de seguir a solução temporária, entre em contato com o Suporte Dell para obter assistência adicional.