PowerFlex. Непрерывная паника процесса SDS в Function MosAsyncIO_ReqAccounting
Summary: Если файл rep_tgt.txt не создан должным образом, во время преобразования SVM вручную или PFMP и модернизации компонента PowerFlex может постоянно происходить сбой SDS.
Symptoms
Процесс SDS постоянно вызывает сбой при следующей трассировке стека:
2024/05/27 08:11:10.051615 Panic in file /data/build/workspace/ScaleIO-Common-Job/src/mos/usr/linux/mos_async_io.c, line 1107, function mosAsyncIO_ReqAccounting, PID 21157.Panic Expression pOsReq->accounting.totalLenSubmittedBytes == pReq->bytesIO /opt/emc/scaleio/sds/bin/sds-4.5.2000.135(mosDbg_PanicPrepare+0xf4) [0x936f74] /opt/emc/scaleio/sds/bin/sds-4.5.2000.135(mosAsyncIO_ReqAccounting+0x26b) [0x95398b] /opt/emc/scaleio/sds/bin/sds-4.5.2000.135() [0x953b4e] /opt/emc/scaleio/sds/bin/sds-4.5.2000.135(mosAsyncIO_Reaper+0xab8) [0x959dc8] /opt/emc/scaleio/sds/bin/sds-4.5.2000.135(mosOsThrd_StartFunc+0x15a) [0x94056a] /lib64/libpthread.so.0(+0xa6ea) [0x7f0629c166ea] [(nil)]
До сбоя SDS журналы трассировки SDS указывают на проблему при чтении из /opt/emc/scaleio/sds/cfg/rep_tgt.txt:
2024/05/27 08:10:36.501247 LOW:7fa41442ddb0:mos_ReadParamFromSysPath:01442: ERROR: Failed to stat sys file /sys/dev/block/0:55/partition, errno: 2 2024/05/27 08:10:36.501253 MED:7fa41442ddb0:mos_GetDevMaxIoSizeBytesFromFD:01565: Could not read parameter for file 28 (path /sys/dev/block/0:55/partition), assuming 256. 2024/05/27 08:10:36.501260 MED:7fa41442ddb0:mosAsyncIO_OpenFileEx:00463: Opened file /opt/emc/scaleio/sds/cfg/rep_tgt.txt (fd 28), maxInflight 8, maxIoSize 256, ptr 0x7fa42c14a450
Затронутые продукты: PowerFlex 3.x и 4.x
Cause
При попытке доступа к файлу rep_tgt.txt возникает проблема с SDS.
Resolution
Если rep_tgt.txt Не существует:
-
-
-
Извлеките необходимые идентификаторы из основного MDM.
- Получите MDM_ID:
scli --query_all | grep ID | head -n1 - Получите SDS_ID: (См. SDS, о котором идет речь)
scli --query_all_sds
- Получите MDM_ID:
-
Создайте файл
rep_tgt.txtс извлеченными идентификаторами. Замените MDM_ID и SDS_ID из приведенного выше выводаecho -n "mdmId=<MDM_ID>,tgtId=<SDS_ID>" > /opt/emc/scaleio/sds/cfg/rep_tgt.txt truncate -s 4096 /opt/emc/scaleio/sds/cfg/rep_tgt.txtПример.
echo -n "mdmId=e7db67b7c2e2190f,tgtId=2514c01a00000003" > /opt/emc/scaleio/sds/cfg/rep_tgt.txt truncate-s 4096 /opt/emc/scaleio/sds/cfg/rep_tgt.txt -
Запустите управляющую программу SDS:
/opt/emc/scaleio/sds/bin/create_service.sh
-
-
Если rep_tgt.txt Существует:
-
-
Убедитесь, что файл содержит правильный идентификатор MDM и идентификатор SDS.
cat /opt/emc/scaleio/sds/cfg/rep_tgt.txt -
Проверьте размер файла (должен быть 4096 байт):
ls -l /opt/emc/scaleio/sds/cfg/rep_tgt.txt -
Если размер файла меньше 4096 байт:
- Создайте резервную копию существующего файла:
cp /opt/emc/scaleio/sds/cfg/rep_tgt.txt /opt/emc/scaleio/sds/cfg/rep_tgt.txt.bak - Измените размер файла:
truncate -s 4096 /opt/emc/scaleio/sds/cfg/rep_tgt.txt - Проверьте новый размер файла
- Создайте резервную копию существующего файла:
- Запустите управляющую программу SDS:
/opt/emc/scaleio/sds/bin/create_service.sh
-
Если после выполнения временного решения паника SDS по-прежнему возникает, обратитесь в службу поддержки Dell за дальнейшей помощью.