Plate-forme de gestion PowerFlex : Impossible de modifier le mot de passe iDRAC lors de l’utilisation de certificats SSL personnalisés
Summary: Le mot de passe iDRAC ne peut pas être modifié via l’interface utilisateur Web de la plate-forme de gestion PowerFlex (PFMP) lors de l’utilisation de certificats SSL personnalisés.
Instructions
Scénario
Le certificat auto-signé PFMP par défaut a été remplacé par un certificat SSL PFMP personnalisé.
Les journaux du Thin-Deployer signalent l’erreur suivante :
requests.exceptions.SSLError: HTTPSConnectionPool(host='10.10.10.25', port=443): Max retries exceeded with url: /httpshare/download/idrac_config_xml/10.10.10.21.config.xml (Caused by SSLError(SSLCertVerificationError(1, '[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:1007)')))
Aug 05,2024 17:05:55 ERROR,An unknown error occurred in snmp_idrac_settings for 10.10.10.21 - 996293b3-9997-4793-a00d-3ce9aa05f78e
ssl.SSLCertVerificationError: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:1007)
raise MaxRetryError(_pool, url, error or ResponseError(cause))
urllib3.exceptions.MaxRetryError: HTTPSConnectionPool(host='10.10.10.25', port=443): Max retries exceeded with url: /httpshare/download/idrac_config_xml/10.10.10.21.config.xml (Caused by SSLError(SSLCertVerificationError(1, '[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:1007)')))
raise SSLError(e, request=request)
Impact
Impossible de mettre à jour le mot de passe des informations d’identification de ressource iDRAC via l’interface utilisateur PFMP sous l’onglet Ressources.
Cause
Le système accède à l’entrée HTTPS à l’aide de son adresse IP externe, mais s’appuie sur le certificat d’autorité de certification interne de la plate-forme PFMP pour la validation du certificat SSL. Si un utilisateur final télécharge son propre certificat SSL d’appliance, le certificat personnalisé remplace le certificat SSL par défaut. Cela inclut les adresses IP en entrée qui correspondent au réseau source. Le réseau iDRAC ne correspond pas à la configuration SAN des certificats personnalisés.
Résolution
- Ouvrez un ticket de support si vous devez utiliser PFxM pour automatiser la modification du mot de passe iDRAC. Cela nécessite de revenir au certificat Ingress PFMP par défaut. Un engagement de support est requis pour effectuer cette opération.
- L’utilisateur final peut modifier manuellement le mot de passe iDRAC via l’interface utilisateur Web de l’iDRAC. Assurez-vous de mettre à jour les informations d’identification iDRAC dans PFxM pour qu’elles correspondent au mot de passe dans l’iDRAC.
Connectez-vous à l’interface utilisateur> Web de l’iDRAC Paramètres >de l’iDRACUtilisateurs Utilisateurs >locaux Modifier >> Enregistrer
Exemple :

Versions affectées
PFMP 4.6.x et versions antérieures