Piattaforma di gestione PowerFlex: Impossibile modificare la password dell'iDRAC quando si utilizzano certificati SSL personalizzati
Summary: La password dell'iDRAC non può essere modificata tramite l'interfaccia utente web di PowerFlex Management Platform (PFMP) quando si utilizzano certificati SSL personalizzati.
Instructions
Scenario
Il certificato autofirmato PFMP predefinito è stato sostituito con un certificato SSL PFMP personalizzato.
I registri thin-deployer riportano il seguente errore:
requests.exceptions.SSLError: HTTPSConnectionPool(host='10.10.10.25', port=443): Max retries exceeded with url: /httpshare/download/idrac_config_xml/10.10.10.21.config.xml (Caused by SSLError(SSLCertVerificationError(1, '[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:1007)')))
Aug 05,2024 17:05:55 ERROR,An unknown error occurred in snmp_idrac_settings for 10.10.10.21 - 996293b3-9997-4793-a00d-3ce9aa05f78e
ssl.SSLCertVerificationError: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:1007)
raise MaxRetryError(_pool, url, error or ResponseError(cause))
urllib3.exceptions.MaxRetryError: HTTPSConnectionPool(host='10.10.10.25', port=443): Max retries exceeded with url: /httpshare/download/idrac_config_xml/10.10.10.21.config.xml (Caused by SSLError(SSLCertVerificationError(1, '[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:1007)')))
raise SSLError(e, request=request)
Impatto
Impossibile aggiornare la password delle credenziali delle risorse iDRAC tramite l'interfaccia utente PFMP nella scheda Resources.
Causa
Il sistema accede all'ingresso HTTPS utilizzando il proprio IP esterno, ma si basa sul certificato CA della piattaforma PFMP interna per la convalida del certificato SSL. Se un utente finale carica il proprio certificato SSL dell'appliance, il certificato personalizzato sostituisce il certificato SSL predefinito. Ciò include gli IP in entrata che corrispondono alla rete di origine. La rete iDRAC non corrisponde alla configurazione SAN con certificati personalizzati.
Risoluzione
- Aprire una richiesta di assistenza se è necessario utilizzare PFxM per automatizzare la modifica della password dell'iDRAC. Ciò richiede il ripristino del certificato PFMP Ingress predefinito. Per eseguire questa operazione è necessario un impegno del supporto.
- L'utente finale può modificare manualmente la password di iDRAC tramite l'interfaccia utente web di iDRAC. Assicurarsi di aggiornare le credenziali iDRAC in PFxM in modo che corrispondano alla password in iDRAC.
Accedere all'interfaccia utente> web di iDRAC Impostazioni iDRAC Utenti>>Utenti locali >Modifica Salva >
Esempio:

Versioni interessate
PFMP 4.6.x e versioni precedenti