PowerFlex Manager: RKE2 yükseltmesi "405 İzin Verilmiyor" hatası nedeniyle art arda başarısız oluyor

Summary: PowerFlex Manager: RKE2 yükseltmesi, yükseltme yükü oluşturulurken "405 İzin Verilmiyor" hatası nedeniyle art arda başarısız oluyor PowerFlex Management Platform (PFMP) yükseltmesi sırasında işlem, http paylaşımında yükseltme yükü klasörü oluşturma noktasında döngüye girerek tekrar tekrar başarısız olur. Hata, HTTP 405 İzin Verilmiyor hatasıyla oluşur. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Etkilenen Sürüm:

Powerflex Manager 4.x

PFMP yükseltmesinin bir parçası olarak RKE2 yükseltmesi gerçekleştiren bir kullanıcı aşağıdaki belirtiler ortaya çıkar:

  • Yükseltme işlemi paketi sürekli olarak indirir ancak yük oluşturma aşamasında başarısız olur.
  • Günlükler alcm pod, http paylaşımında yükseltme yükü klasörünü oluşturmaya çalışırken '405 İzin Verilmiyor' hatasını gösteriyor
    2024-11-30T06:37:50.452413347-06:00 stdout F 2024-11-30 12:37:50 [pool-2-thread-1] (UpgradePFMP.java:168) [INFO] Starting PFMP upgrade
    ..
    2024-11-30T06:49:06.712045703-06:00 stdout F 2024-11-30 12:49:06 [pool-2-thread-1] (UpgradePFMP.java:718) [DEBUG] PFMP Bundle download progress 100%
    ..
    2024-11-30T06:53:47.628162548-06:00 stdout F 2024-11-30 12:53:47 [pool-2-thread-1] (UpgradePFMP.java:1681) [INFO] Current RKE2 version: 1.25.3
    2024-11-30T06:53:47.629703367-06:00 stdout F 2024-11-30 12:53:47 [pool-2-thread-1] (UpgradePFMP.java:1688) [INFO] Available RKE2 version: 1.26.13
    ...
    024-11-30T06:54:02.071950984-06:00 stdout F 2024-11-30 12:54:02 [pool-2-thread-1] (ExecuteSystemCommands.java:106) [DEBUG] Moving RKE2 artifacts to upgrade-artifacts folder . . .
    2024-11-30T06:54:02.344803044-06:00 stdout F 2024-11-30 12:54:02 [pool-2-thread-1] (ExecuteSystemCommands.java:106) [DEBUG] /opt/Dell/ASM/temp/upgrade853246658060560317/Upgrade/prepare-upgrade.sh: line 264: kubectl: command not found
    2024-11-30T06:54:02.368496491-06:00 stdout F 2024-11-30 12:54:02 [pool-2-thread-1] (ExecuteSystemCommands.java:106) [DEBUG] Creating upgrade payload folder in http-share . . .<html>
    2024-11-30T06:54:02.368527723-06:00 stdout F 2024-11-30 12:54:02 [pool-2-thread-1] (ExecuteSystemCommands.java:106) [DEBUG] <head><title>405 Not Allowed</title></head>
    2024-11-30T06:54:02.368533448-06:00 stdout F 2024-11-30 12:54:02 [pool-2-thread-1] (ExecuteSystemCommands.java:106) [DEBUG] <body>
    2024-11-30T06:54:02.368548798-06:00 stdout F 2024-11-30 12:54:02 [pool-2-thread-1] (ExecuteSystemCommands.java:106) [DEBUG] <center><h1>405 Not Allowed</h1></center>
    2024-11-30T06:54:02.368553418-06:00 stdout F 2024-11-30 12:54:02 [pool-2-thread-1] (ExecuteSystemCommands.java:106) [DEBUG] <hr><center>nginx/1.21.5</center>
    2024-11-30T06:54:02.368565659-06:00 stdout F 2024-11-30 12:54:02 [pool-2-thread-1] (ExecuteSystemCommands.java:106) [DEBUG] </body>
    2024-11-30T06:54:02.36859845-06:00 stdout F 2024-11-30 12:54:02 [pool-2-thread-1] (ExecuteSystemCommands.java:106) [DEBUG] </html>
    2024-11-30T06:54:02.369264313-06:00 stdout F 2024-11-30 12:54:02 [pool-2-thread-1] (ExecuteSystemCommands.java:106) [DEBUG]  done.

 

Cause

PFMP, düğüm düzeyinde RKE2 yükseltmeleri için httpshare-ingress-upload girişini kullanarak düğüm yükseltme modüllerinin karşıya yüklenmesini sağlar.
Dell destek sitesi tarafından sağlanan bir komut dosyası "CMO_Patch.zip", bir güvenlik açığını azaltmak için http paylaşımı yükleme özelliklerini kısıtlayarak yükseltme hatalarına neden olur.

 

Resolution

Geçici Çözüm

  • Httpshare-ingress-upload girişinin mevcut olmadığından emin olun

    kubectl get ingress -A | egrep httpshare-ingress
  • YAML dosyasını aktarın:
    Bu KB'ye ekli "httpshare-ingress-upload.zip" dosyasını MVM düğümlerinden birine kopyalayın ve ayıklayın.

  • Giriş düzeltmesini uygulayın:
    MVM düğümünde oturum açın, YAML dosyasının depolandığı dizine gidin ve ayarları uygulayın:

    kubectl apply -f httpshare-ingress-upload.yaml
  • Giriş oluşturmayı doğrulayın:
    httpshare-ingress-upload girişinin başarıyla oluşturulduğundan emin olun. IP adreslerinin doldurulması 15-30 saniye sürebilir. Şununla kontrol edin:

    kubectl get ingress -n powerflex | egrep -i httpshare
  • Alcm bölmesini yeniden başlatın

    kubectl delete pod $(kubectl get pods -n powerflex | egrep alcm | awk '{print $1}') -n powerflex
  • Yükseltmenin çalışıp çalışmadığını görmek için aclm pod günlüklerini kontrol edin. Değilse, PFMP Yükseltmesini yeniden deneyin:
    Yükseltme işlemini yeniden başlatın. Sorun artık çözülmüş olmalıdır.

 

Yükseltme Sonrası İşlemler:

PFMP yükseltmesi tamamlandıktan sonra, PFMP sürümünüze bağlı olarak aşağıdaki adımları izleyin:

  • 4.6.1'den önceki PFMP sürümlerini çalıştıran sistemler için:

    • Güvenlik uyumluluğunun devam etmesini sağlamak için CVE düzeltme aracını (CMO_Patch.zip) yeniden uygulayın. Powerflex Manager CVE-2024-37143 için KB Düzeltmesine bakın (Bu makaleyi görüntülemek için Dell Destek hesabı gereklidir)
      Not: Gelecekteki yükseltmeler için, sistem 4.6.1 veya daha yeni bir sürüme yükseltilmedikçe yukarıda belirtilen geçici çözüm tekrar uygulanmalıdır.
  • PFMP sürüm 4.6.1 veya üzerini çalıştıran sistemler için:

    • Yükseltmeden sonra ek bir işlem yapılması gerekmez.

 

Sorunun Düzeltildiği Sürüm: PowerFlex Manager 4.6.1

Additional Information

Önemli

PFMP (Powerflex Manager) kurulumu daha önce kök kullanıcı olarak gerçekleştirildiyse, PFMP yükseltmesine devam etmeden önce aşağıdaki dizinlerin sahipliğinin uygun şekilde güncellendiğinden emin olun. Daha fazla ayrıntı için bkz. PowerFlex Yönetim Platformu - PFXM Yükseltmesi Görevde Başarısız Oluyor Artifacts Destination için Açılış Dizini Temizle

Products

PowerFlex rack, PowerFlex Appliance, PowerFlex custom node, PowerFlex Software
Article Properties
Article Number: 000261179
Article Type: Solution
Last Modified: 22 Jan 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.