PowerFlex Manager: RKE2 升級會因為「405 不允許」錯誤而重複失敗
Summary: PowerFlex Manager: RKE2 升級在建立升級有效負載時,由於「405 不可允許」錯誤而重複失敗 在 PowerFlex 管理平台 (PFMP) 升級期間,程序會重複失敗,並在 http 共用中建立升級裝載資料夾時迴圈。此故障發生時發生 HTTP 405 不允許錯誤。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
受影響的版本:
Powerflex Manager 4.x
當使用者在 PFMP 升級過程中執行 RKE2 升級時,會出現下列症狀:
- 升級程序會持續下載套裝,但在建立承載階段失敗。
- 記錄來自
alcm當嘗試在 HTTP 共用中建立升級裝載資料夾時,pod 顯示錯誤「405 不允許」2024-11-30T06:37:50.452413347-06:00 stdout F 2024-11-30 12:37:50 [pool-2-thread-1] (UpgradePFMP.java:168) [INFO] Starting PFMP upgrade .. 2024-11-30T06:49:06.712045703-06:00 stdout F 2024-11-30 12:49:06 [pool-2-thread-1] (UpgradePFMP.java:718) [DEBUG] PFMP Bundle download progress 100% .. 2024-11-30T06:53:47.628162548-06:00 stdout F 2024-11-30 12:53:47 [pool-2-thread-1] (UpgradePFMP.java:1681) [INFO] Current RKE2 version: 1.25.3 2024-11-30T06:53:47.629703367-06:00 stdout F 2024-11-30 12:53:47 [pool-2-thread-1] (UpgradePFMP.java:1688) [INFO] Available RKE2 version: 1.26.13 ... 024-11-30T06:54:02.071950984-06:00 stdout F 2024-11-30 12:54:02 [pool-2-thread-1] (ExecuteSystemCommands.java:106) [DEBUG] Moving RKE2 artifacts to upgrade-artifacts folder . . . 2024-11-30T06:54:02.344803044-06:00 stdout F 2024-11-30 12:54:02 [pool-2-thread-1] (ExecuteSystemCommands.java:106) [DEBUG] /opt/Dell/ASM/temp/upgrade853246658060560317/Upgrade/prepare-upgrade.sh: line 264: kubectl: command not found 2024-11-30T06:54:02.368496491-06:00 stdout F 2024-11-30 12:54:02 [pool-2-thread-1] (ExecuteSystemCommands.java:106) [DEBUG] Creating upgrade payload folder in http-share . . .<html> 2024-11-30T06:54:02.368527723-06:00 stdout F 2024-11-30 12:54:02 [pool-2-thread-1] (ExecuteSystemCommands.java:106) [DEBUG] <head><title>405 Not Allowed</title></head> 2024-11-30T06:54:02.368533448-06:00 stdout F 2024-11-30 12:54:02 [pool-2-thread-1] (ExecuteSystemCommands.java:106) [DEBUG] <body> 2024-11-30T06:54:02.368548798-06:00 stdout F 2024-11-30 12:54:02 [pool-2-thread-1] (ExecuteSystemCommands.java:106) [DEBUG] <center><h1>405 Not Allowed</h1></center> 2024-11-30T06:54:02.368553418-06:00 stdout F 2024-11-30 12:54:02 [pool-2-thread-1] (ExecuteSystemCommands.java:106) [DEBUG] <hr><center>nginx/1.21.5</center> 2024-11-30T06:54:02.368565659-06:00 stdout F 2024-11-30 12:54:02 [pool-2-thread-1] (ExecuteSystemCommands.java:106) [DEBUG] </body> 2024-11-30T06:54:02.36859845-06:00 stdout F 2024-11-30 12:54:02 [pool-2-thread-1] (ExecuteSystemCommands.java:106) [DEBUG] </html> 2024-11-30T06:54:02.369264313-06:00 stdout F 2024-11-30 12:54:02 [pool-2-thread-1] (ExecuteSystemCommands.java:106) [DEBUG] done.
Cause
PFMP 仰賴 httpshare-ingress-upload 入口進行節點層級 RKE2 升級,以啟用節點升級模組的上傳。
Dell 支援網站提供的指令檔「CMO_Patch.zip」會限制 HTTP 共用上傳功能,以緩解漏洞,導致升級失敗。
Resolution
因應措施
-
請確認 httpshare-ingress-upload 入口不存在
kubectl get ingress -A | egrep httpshare-ingress
-
傳輸 YAML 檔案:
將附加至此 KB 的「httpshare-ingress-upload.zip」檔案複製到其中一個 MVM 節點,並將其解壓縮。 -
套用入口修正:
登入 MVM 節點,前往儲存 YAML 檔案的目錄,然後套用設定:kubectl apply -f httpshare-ingress-upload.yaml
-
驗證入口建立:
確定已成功建立 httpshare-ingress-upload 入口。填入 IP 位址可能需要 15 至 30 秒的時間。請檢查:kubectl get ingress -n powerflex | egrep -i httpshare
-
重新啟動 alcm pod
kubectl delete pod $(kubectl get pods -n powerflex | egrep alcm | awk '{print $1}') -n powerflex -
檢查 aclm Pod 記錄,查看升級是否正在執行中。如果沒有,請重試 PFMP 升級:
再次開始升級程序。現在應該可以解決此問題。
升級後動作:
PFMP 升級完成後,請根據您的 PFMP 版本,按照下列步驟操作:
-
執行 4.6.1 之前 PFMP 版本的系統:
- 重新套用 CVE 補救工具 (CMO_Patch.zip),以確保持續符合安全性法規。請參閱 Powerflex Manager CVE-2024-37143 的 KB 補救措施 (需要 Dell 支援帳戶才能檢視此文章)
注意:若要進行任何日後升級,除非系統升級至 版本 4.6.1 或更新版本,否則必須再次套用上述因應措施。
- 重新套用 CVE 補救工具 (CMO_Patch.zip),以確保持續符合安全性法規。請參閱 Powerflex Manager CVE-2024-37143 的 KB 補救措施 (需要 Dell 支援帳戶才能檢視此文章)
-
若為執行 PFMP 版本 4.6.1 或更新版本的系統:
- 升級後不需要執行其他動作。
已修正問題的版本:PowerFlex Manager 4.6.1
Additional Information
重要
如果先前以 root 使用者的身分執行 PFMP (Powerflex Manager) 安裝,請確定下列目錄的擁有權已適當更新,再繼續進行 PFMP 升級。如需更多詳細資訊,請參閱 PowerFlex 管理平台 - PFXM 升級在工作時失敗 清除登陸 成品目錄 目的地
Products
PowerFlex rack, PowerFlex Appliance, PowerFlex custom node, PowerFlex SoftwareArticle Properties
Article Number: 000261179
Article Type: Solution
Last Modified: 22 Jan 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.