PowerMax : Les commandes Symcli échouent « La fonctionnalité demandée n’est pas prise en charge pour cette version du microcode ou SYMAPI »

Summary: PowerMax : Les commandes Symcli échouent avec l’erreur « La fonctionnalité demandée n’est pas prise en charge pour cette version du microcode ou SYMAPI » après la mise à niveau de PowerMaxOS 10.2 . Toutes les commandes de Solutions Enabler (symcli) échouent avec l’erreur « La fonctionnalité demandée n’est pas prise en charge pour cette version du microcode ou SYMAPI » après la mise à niveau de PowerMaxOS vers la version 10.2 (Magnolia) dans la baie. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Toutes les commandes Solutions Enabler (symcli) renvoient l’erreur « La fonctionnalité demandée n’est pas prise en charge pour cette version du microcode ou SYMAPI » après la mise à niveau de PowerMaxOS vers la version 10.2 

Cause

La version autonome de Solutions Enabler n’est pas compatible avec la version PowerMaxOS exécutée dans la baie.

Solutions Enabler 10.2 est la version prise en charge pour la gestion des baies PowerMaxOS 10.2.

Il en va de même pour SE 10.3 

La version SE 10.3 est nécessaire pour gérer la baie fonctionnant sous PowerMax OS 10.3

 

 

Resolution

Pour vérifier la version de Solutions Enabler, exécutez la commande suivante à partir de l’hôte :

symcli

 

Guide d’installation et de configuration de Dell Solutions Enabler 10.3.0 

dl.dell.com/content/manual35241739-dell-solutions-enabler-10-3-0-installation-and-configuration-guide.pdf?language=en-us

 

L’accès à la base de données SYMAPI n’est pas compatible en amont, car une bibliothèque SYMAPI ne peut pas accéder à une base de données créée par une version plus récente d’une application SYMAPI. Si, par exemple, la version de la bibliothèque locale est désynchronisée par rapport à la version de la base de données SYMAPI locale (en tant qu’appel de bibliothèque SYMAPI V8.0 provenant d’un client SYMAPI tentant d’accéder à une base de données V10.3), une erreur est renvoyée : SYMAPI_C_DB_FILE_TOO_NEW. Cette restriction concerne uniquement les bases de données locales. Dans les environnements client/serveur, les accès à une base de données de serveur d’une version ultérieure sont automatiquement résolus par le serveur SYMAPI, qui effectue toutes les traductions nécessaires des informations entre le client et le serveur.

Affected Products

PowerMax, PowerMax 2500, PowerMax 8500, Solutions Enabler

Products

Solutions Enabler
Article Properties
Article Number: 000297022
Article Type: Solution
Last Modified: 26 Nov 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.